gazebo_ros_control and effort limit

asked 2016-09-10 13:59:41 -0500

updated 2016-09-10 17:25:19 -0500

Hello,

I am trying to simulate an heavy robot (around 2 tonnes) in Gazebo. My robot is using wheels, these wheels are controlled by speed. The problem is that when something push my robot (not too much, so the robot should not move) the wheels (controlled to the speed 0) are moving (not sliding, I see them rotating). It seems that the velocityControl was not able to apply enough effort (to maintain the speed to 0).

My joints are continious joints. Declared with velocity_controllers/JointVelocityController. In the URDF I have set for my joints:

  <limit
  lower="-2147483647"
  upper="2147483647"
  effort="2147483647"
  velocity="0.5"/>

Even If I have read in the gazebo documentation that in the case of a continious joint, limits are ignored.

So i wonder if in the case of a VelocityJointInterface there is an effortLimit ? And how could I set it to a bigger value

Thanks.

edit retag flag offensive close merge delete

Comments

In the gz sdf code it seems that a continious joint is transformed into a revolute with 1e16 limits. And the given effort is ignored.

GuillaumeB gravatar image GuillaumeB  ( 2016-09-12 12:56:35 -0500 )edit

I have the same problem here, when the robot is said to maintain speed 0 it is rolling away. Have you solved the problem since then?

Westranger gravatar image Westranger  ( 2017-10-26 05:39:30 -0500 )edit

I didn't solved it. But maybe you can try to code your own gazebo controllers

GuillaumeB gravatar image GuillaumeB  ( 2017-10-27 10:24:56 -0500 )edit