Ask Your Question
1

error loading gazebo_plugins models (Pioneer)

asked 2016-09-07 13:23:00 -0500

updated 2016-09-08 09:37:57 -0500

I get one weird error trying to load some of the samples/models provided in gazebo_plugins on Ubuntu 16.04 with ROS kinetic installed via official repositories.

Particularly, for the multi_robot_scenario fails. On the other hand the tricycle demo or the pendulum demos work properly.

This is the error I get trying to load the multi_robot_scenario demo.

Error [Param.cc:451] Unable to set value [-nan -nan -nan] for key[size]
gzserver: /build/ogre-1.9-mqY1wq/ogre-1.9-1.9.0+dfsg1/OgreMain/src/OgreNode.cpp:630: virtual void Ogre::Node::setScale(const Ogre::Vector3&): Assertion `!inScale.isNaN() && "Invalid vector supplied as parameter"' failed.
[r1/urdf_spawner-4] process has finished cleanly
log file: /home/geus/.ros/log/37a5e414-7527-11e6-8e8a-d8cb8abfd844/r1-urdf_spawner-4*.log
Service call failed: transport error completing service call: unable to receive data from sender, check sender's logs for details
Aborted (core dumped)
[gazebo-2] process has died [pid 19670, exit code 134, cmd /media/geus/Storage/simulation_gazebo/src/gazebo_ros_pkgs/gazebo_ros/scripts/gzserver -e ode worlds/empty.world __name:=gazebo __log:=/home/geus/.ros/log/37a5e414-7527-11e6-8e8a-d8cb8abfd844/gazebo-2.log].
log file: /home/geus/.ros/log/37a5e414-7527-11e6-8e8a-d8cb8abfd844/gazebo-2*.log

In order to reproduce this issue you have to install the package ros-kinetic-gazebo-plugins and execute the launch file:

roslaunch $(rospack find gazebo_plugins)/test/multi_robot_scenario/launch/multi_robot_scenario.launch

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
3

answered 2016-09-08 13:34:45 -0500

I finally found the solution.

It looks like there is a bug in gazebo 7.0.0 contained in the kinetic debian package repository for ubuntu 16.04. The bug appears when the urdf descriptions contains collision geometry objects with zero value parameters.

For instance in "gazebo_plugins/test/multi_robot_scenario/xacro/p3dx/pioneer3dx_wheel.xacro": we find this chunk of urdf:

<collision>
  <origin xyz="0 0 0" rpy="0 0 0"/>
  <geometry>
    <box size="0 0 0"/>
  </geometry>
</collision>

The box size must not be zero. The error is solved if the above code chunk is replaced by the code chunk below:

<collision>
  <origin xyz="0 0 0" rpy="0 0 0"/>
  <geometry>
    <box size="0.1 0.1 0.1"/>
  </geometry>
</collision>

It is needed to apply this correction in several place in order to make work this demo:

roslaunch $(rospack find gazebo_plugins)/test/multi_robot_scenario/launch/multi_robot_scenario.launch

edit flag offensive delete link more

Comments

Hm. Is this a regression in Gazebo 7? In any case, it would be really nice if you could report this to the Gazebo bug tracker or the gazebo_plugins tracker. Even if 0 0 0 is not a legal value, Gazebo should not just crash, imo.

gvdhoorn gravatar image gvdhoorn  ( 2016-09-09 00:53:50 -0500 )edit

@Pablo-Iñigo-Blasco, what files did you need to change (if you can still remember)? I changed the battery_block, sonar, swivel, sonar, and wheel xacro files and it still didn't fix the issue. I'm wondering if I missed one.

jayess gravatar image jayess  ( 2017-08-08 14:06:36 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-09-07 13:23:00 -0500

Seen: 1,271 times

Last updated: Sep 08 '16