Ask Your Question
0

sudo apt-get ros-kinetic-rtabmap-ros E: unable to locate package

asked 2016-08-29 12:19:46 -0500

Mate gravatar image

updated 2016-08-29 12:34:17 -0500

I am using Ubuntu Mate 16.04 on Raspberry Pi 2. And ROS kinetic base is installed on it, every other package installs easily but I am unable to resolve the issue while installing rtabmap-ros. I have tried using ubuntu 16.04.1 LTS image for ARM and installed a Lubuntu desktop on it but the error is still present.

edit retag flag offensive close merge delete

Comments

Maybe the package just is not released?

dornhege gravatar imagedornhege ( 2016-08-29 12:24:12 -0500 )edit

I have tried on my desktop with Ubuntu 16.04.1 LTS it gets installed easily.

Mate gravatar imageMate ( 2016-08-29 13:07:52 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
4

answered 2016-08-29 13:15:04 -0500

matlabbe gravatar image

updated 2016-08-29 13:32:38 -0500

Hi,

Binaries for arm are not built because libpcl-dev was not found on the initial release of Kinetic: https://github.com/introlab/rtabmap/i... , so rtabmap build is disabled on arm (don't remember where exactly on the buildfarm it is set).We may check to re-enable if libpcl-dev is now released. For now, you may have to build rtabmap from source: https://github.com/introlab/rtabmap_r...

Build status: http://repositories.ros.org/status_pa...

EDIT: It looks like pcl_ros package is not built either: http://repositories.ros.org/status_pa...

cheers

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2016-08-29 12:19:46 -0500

Seen: 1,030 times

Last updated: Aug 29 '16