Ask Your Question

Why ar_track_alvar is not installing?

asked 2016-08-09 10:37:08 -0600

anilmullapudi gravatar image

updated 2016-08-09 12:36:38 -0600

When i try to install the ar_track_alvar using sudo apt-get install ros-indigo-ar-track-alvar
I was getting the following error.

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package ros-indigo-ar-track-alvar

I also tried using synaptic tool which is alternative to apt-get install. But i was not able to find indigo related alvar packages image description

Can anyone please help me on this?

edit retag flag offensive close merge delete


ar_track_alvar is listed as released for Indigo, so that should work if you're using Indigo that was installed through apt on Ubuntu x86. Perhaps you're using a different OS or a different CPU?

ahendrix gravatar imageahendrix ( 2016-08-09 11:42:29 -0600 )edit

Here is my OS details

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 14.04.5 LTS
Release: 14.04
Codename: trusty

anilmullapudi gravatar imageanilmullapudi ( 2016-08-09 12:02:35 -0600 )edit

The build status page and the arm build status page show that ar_track_alvar is built and stable for Ubuntu Trusty x86, amd64 and armhf architectures,

ahendrix gravatar imageahendrix ( 2016-08-09 12:29:15 -0600 )edit

Did you install ROS through apt or from source? Are your apt sources set up correctly?

ahendrix gravatar imageahendrix ( 2016-08-09 12:29:40 -0600 )edit

Your system reports that it's running Ubuntu 14.04 (Trusty), but the ROS packages listed are for Ubuntu 12.04 (Precise). Did you have a previous version of ROS installed? Did you upgrade from a previous version of Ubuntu?

ahendrix gravatar imageahendrix ( 2016-08-09 12:47:46 -0600 )edit

ROS was installed through apt-get
rosversion -d

anilmullapudi gravatar imageanilmullapudi ( 2016-08-09 12:51:52 -0600 )edit

Thank you so much for your support, i re-installed the ros indigo keys. i was able to install the ar_track_alvar now.

anilmullapudi gravatar imageanilmullapudi ( 2016-08-09 13:11:06 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2016-08-09 13:13:17 -0600

anilmullapudi gravatar image

I followed 1.2 and 1.3 from this link and sudo apt-get update

above steps worked for me, now i was able to install

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2016-08-09 10:37:08 -0600

Seen: 545 times

Last updated: Aug 09 '16