Ask Your Question
0

Stuck on spamming terminal Beginner

asked 2016-08-03 15:23:17 -0500

KasperJ gravatar image

I am following the book "Learning ROS for robotics programming" and while trying to create a workspace i screwed something up.

I rebooted thinking it would fix the problem, but now i am stuck with a terminal spamming

bash: export: `ROS_PACKAGE_PATH/dev/rosbook:/opt/ros/kinetic/share:/opt/ros/kinetic/stacks': not a valid identifier
$: command not found

endlessly and i have no idea how to stop it.

As the title indicates i am new to this ROS stuff so bear with me if i sound like a complete moron.

I will do my best to add additional info if required.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-08-03 16:12:15 -0500

Mark Rose gravatar image

Did you forget the '$' in the variable ROS_PACKAGE_PATH? It looks like your Bash startup script has something like this:

export PATH=ROS_PACKAGE_PATH/dev/rosbook:$PATH

You probably need the '$' before ROS_PACKAGE_PATH.

But... I don't know that book, but if the examples are designed to run using rosrun or roslaunch, then you don't need to add the rosbook stuff to the path, as rosrun and roslaunch will search your packages. Did you install the example code according to their directions? (You can't just pick any directory when using ROS with the catkin built tool.)

edit flag offensive delete link more

Comments

http://www.ict.griffith.edu.au/~vlad/...

chapter 2 page 40 the chapter called "creating our workspace"

It is still spamming the terminal.

KasperJ gravatar image KasperJ  ( 2016-08-03 16:59:18 -0500 )edit

after i did

 $ echo "export ROS_PACKAGE_PATH"~/dev/rosbook:${ROS_PACKAGE_PATH}" >>
~/.bashrc
$ . ~/.bashrc

the next step was to create a ROS package, but the line was stuck with > in front of my command, and so nothing happend when i entered the commands to make a ROS package.

KasperJ gravatar image KasperJ  ( 2016-08-03 17:01:17 -0500 )edit

thus the reboot.

KasperJ gravatar image KasperJ  ( 2016-08-03 17:01:33 -0500 )edit

It sounds like you forgot the ending quotation mark. That might have caused the '>' to show in front of the command.

Sam94 gravatar image Sam94  ( 2016-08-03 20:14:14 -0500 )edit

how do i stop the spamming terminal then?

KasperJ gravatar image KasperJ  ( 2016-08-03 20:30:25 -0500 )edit

Try opening your .bashrc file with a text editor and look for the line that the terminal keeps spamming. Remove that line and restart the ROS tutorial. Your .bashrc file should be in your home directory, type "ls -a" to see it.

Sam94 gravatar image Sam94  ( 2016-08-03 20:52:23 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-08-03 15:23:17 -0500

Seen: 182 times

Last updated: Aug 03 '16