ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Error Running Catkin_Make

asked 2016-07-31 19:59:48 -0500

jwasserstein gravatar image

updated 2016-07-31 22:42:18 -0500

After installing/uninstalling some packages from source using rosinstall, I can no longer run catkin_make without error. I've tried removing the packages I installed, removing/reinstalling the catkin package, running wstool update, and other things.

The error message makes reference to catkin_EXTRAS_DIR, but I can't seem to find any information on what this is.

Can anyone help me understand what I can do to fix this? What is catkin_EXTRAS_DIR?

pi@raspberrypi:~/ros_catkin_ws $ catkin_make
Base path: /home/pi/ros_catkin_ws
Source space: /home/pi/ros_catkin_ws/src
Build space: /home/pi/ros_catkin_ws/build
Devel space: /home/pi/ros_catkin_ws/devel
Install space: /home/pi/ros_catkin_ws/install
#### Running command: "make cmake_check_build_system" in "/home/pi/ros_catkin_ws/build"
-- +++ catkin
-- Using CATKIN_DEVEL_PREFIX: /home/pi/ros_catkin_ws/devel
-- Using CMAKE_PREFIX_PATH: /home/pi/ros_catkin_ws/build;/home/pi/ros_catkin_ws/build/cmake
-- Using PYTHON_EXECUTABLE: /usr/bin/python
-- Using Debian Python package layout
-- Using empy: /usr/bin/empy
-- Call enable_testing()
-- Using CATKIN_TEST_RESULTS_DIR: /home/pi/ros_catkin_ws/build/test_results
-- Found gtest sources under '/usr/src/gtest': gtests will be built
-- Using Python nosetests: /usr/bin/nosetests-2.7
-- catkin 0.6.18
CMake Error at catkin/cmake/assert.cmake:3 (message):

  Assertion failed: catkin_EXTRAS_DIR (value is '')

Call Stack (most recent call first):
  catkin/cmake/catkin_workspace.cmake:34 (assert)
  CMakeLists.txt:28 (catkin_workspace)

-- Configuring incomplete, errors occurred!
See also "/home/pi/ros_catkin_ws/build/CMakeFiles/CMakeOutput.log".
See also "/home/pi/ros_catkin_ws/build/CMakeFiles/CMakeError.log".
Makefile:9532: recipe for target 'cmake_check_build_system' failed
make: *** [cmake_check_build_system] Error 1
Invoking "make cmake_check_build_system" failed

Thanks, Justin

edit retag flag offensive close merge delete


Please post your error message as text and format it with the "preformatted text" (010101) button so that it is searchable and readable.

ahendrix gravatar image ahendrix  ( 2016-07-31 22:07:07 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2016-08-01 01:33:51 -0500

ahendrix gravatar image

It's not entirely clear exactly what you've done to get here, but it's clear that your workspace is kind of messed up.

catkin_EXTRAS_DIR is one of the variables used internally by catkin during the build process; if it's not set it means that some file for catkin is corrupt or empty.

The first steps at troubleshooting would be to remove the build and devel directories in your workspace, and since the CMakeLists.txt link at the root of your workspace seems messed up, you should remove that too. A fresh build will re-create all of these.

After that, next steps will depend on how you installed ROS. If you did a binary install, you should reinstall any apt packages you suspect are damaged with apt-get install --reinstall <package>. If you did a source install, you should make sure that the source files are still intact, and then run the build steps (catkin_make_isolated, etc) again.

edit flag offensive delete link more


I tried removing build, devel, and CMakeLists.txt, then building again, but this didn't work. I ended up re-installing ROS which fixed the issue. I also had some boot issues which I attributed to a corrupt SD card, so that might be what caused this. Thanks for your help.

jwasserstein gravatar image jwasserstein  ( 2016-08-01 15:08:22 -0500 )edit

Question Tools

1 follower


Asked: 2016-07-31 19:59:48 -0500

Seen: 872 times

Last updated: Aug 01 '16