Ask Your Question

Fail: ABORTED: No motion plan found. No execution attempted

asked 2016-07-30 02:02:48 -0600

FaredEtman gravatar image

I have used moveit api but with function "group.setPoseTarget(pose1)" it give " Fail: ABORTED: No motion plan found. No execution attempted" and at terminal of rviz it give

[ INFO] [1469775045.492605776]: LBKPIECE1: Created 1 (1 start + 0 goal) states in 1 cells (1 start (1 on boundary) + 0 goal (0 on boundary))

can any one tell me how to solve this problem?

edit retag flag offensive close merge delete


Have you solved it?

bhavyadoshi26 gravatar imagebhavyadoshi26 ( 2016-12-21 08:38:42 -0600 )edit

Do you solve this problem? I have the same error, but I don't know how to solve it

zichenxiaoxu gravatar imagezichenxiaoxu ( 2019-02-20 01:32:15 -0600 )edit

2 Answers

Sort by » oldest newest most voted

answered 2016-12-21 09:28:07 -0600

v4hn gravatar image

updated 2017-10-08 08:03:43 -0600

This can have several causes.

  • pose1 might simply be unreachable by the arm -> use a pose of which you know that it is reachable
  • pose1 is reachable but the inverse kinematics plugin failed to find a joint configuration that results in the end-effector being near that pose -> use a different IK or different parameters (trac_ik or a specialized ikfast perform good)
  • The planner failed to find a path to the goal -> is there a path by which you can move from the current configuration to the goal configuration (within the specified software limits)
  • if there are paths the planner should be able to find, you might want to try a different planner -> e.g. group.setPlannerId("RRTConnectkConfigDefault")
  • the planner might find the path with more time available -> group.setPlanningTime(<insert-time-limit-here>)
edit flag offensive delete link more



Hi, I have a question that before I set the pose goal, how can I know whether the pgose goal is reachable? Is there any funtion in moveit to solve this problem?

tengfei gravatar imagetengfei ( 2017-12-02 05:15:17 -0600 )edit

Is there a Python functionality for that?

nmelchert gravatar imagenmelchert ( 2018-09-10 08:59:01 -0600 )edit

answered 2017-02-08 11:49:05 -0600

FábioBarbosa gravatar image

I was having the same problem, so thanks for the help. What tick it on to work was to wirte: group.setPlanningTime(10);

When i run the robot planning program theres only one thing bodering me which is this:

[ INFO] [1486575608.470163274]: No optimization objective specified, defaulting to PathLengthOptimizationObjective
[ INFO] [1486575608.470393526]: No planner specified. Using default.

I dont understand why i dont have a planner if the GUI tells me that it is OMPL and shows green. Is this problem too?

edit flag offensive delete link more


"No planner specified" means you did not explicitly specify which of OMPL's planners you wanted to use. The default one is selected in this case.

v4hn gravatar imagev4hn ( 2017-10-08 08:05:24 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools



Asked: 2016-07-30 02:02:48 -0600

Seen: 4,839 times

Last updated: Feb 20 '19