Hector_slam Transform is always 0,0,0

asked 2016-07-28 14:15:00 -0600

23tg94 gravatar image

Hello Everyone,

I have been chasing this around for a few days now and have no clue whats going on. Not sure if I'm just doing something stupid. When I run hector with the xv_11 lidar I get a perfect map and everything works fine. I can move the lidar around and generate a map and everything. I went to grab the transform to see what my x and y are and they are always 0. for example if i run

rosrun tf tf_echo /map /base_link

I get:

At time 1469733057.877
- Translation: [1.000, 0.000, 0.000]
- Rotation: in Quaternion [0.000, 0.000, 0.000, 1.000]
            in RPY (radian) [0.000, -0.000, 0.000]
            in RPY (degree) [0.000, -0.000, 0.000]

No matter what i do i get this transform. I did a project earlier that used hector_slam and gazebo and this gave me my current transform in the map.

hector_slam_launch file: <launch> <node pkg="hector_mapping" type="hector_mapping" name="hector_mapping" output="screen">

<param name="pub_map_odom_transform" value="true"/>
<param name="map_frame" value="map"/> 
<param name="base_frame" value="base_link"/> 
<param name="odom_frame" value="base_link"/>

<param name="use_tf_scan_transformation" value="true"/>
<param name="use_tf_pose_start_estimate" value="false"/>

<param name="map_resolution" value="0.050"/>
<param name="map_size" value="2048"/>
<param name="map_start_x" value="0.5"/>
<param name="map_start_y" value="0.5" />
<param name="map_pub_period" value="1.0" />
<param name="map_multi_res_levels" value="2" />

<param name="update_factor_free" value="0.4"/>
<param name="update_factor_occupied" value="0.7" />    
<param name="map_update_distance_thresh" value="0.2"/>
<param name="map_update_angle_thresh" value="0.9" />
<param name="laser_max_dist" value="6" />
<param name="laser_z_min_value" value = "-1.0" />
<param name="laser_z_max_value" value = "1.0" />

<param name="advertise_map_service" value="true"/>
<param name="scan_subscriber_queue_size" value="5"/>
<param name="scan_topic" value="scan"/>
<param name="tf_map_scanmatch_transform_frame_name" value="scanmatcher_frame" />

</node> </launch>

if you need anything else let me know and any help is greatly appreciated.

Thanks

edit retag flag offensive close merge delete