Ask Your Question
1

Hokuyo laser - Turtlebot costmap updation error

asked 2016-07-20 08:55:15 -0500

R@m gravatar image

Hello people,

We have a turtlebot(kobuki base) and have connected Hokuyo laser to it following the instructions from these links.

Previously when we tested AMCL with Kinect (as available with the turtlebot), the indoor navigation was fine and the map was updated with dynamic obstacles(like person walking in front of it, sudden obstacle not available in map) introduced then and there, and the turtlebot was able to avoid them and reach the goal.

When we tried the same with Hokuyo laser, we were able to map the area using gmapping, do AMCL as well with it and the robot was able to reach the goal. But the robot was not able to update itself with dynamic obstacles introduced. It was able to see only the static mapped obstacles and couldn't avoid dynamic obstacles while reaching its goal. Not sure if any navigation parameters are to be modified. Could anyone please help on the same???

edit retag flag offensive close merge delete

Comments

A solution that worked for me was to play with the "max_obstacle_height", "min_obstacle_height" and "z_origin" parameters

medjo gravatar imagemedjo ( 2017-05-12 09:05:00 -0500 )edit

Will try out and let you know @medjo. And may i know the values you had assigned for those parameters?

R@m gravatar imageR@m ( 2017-05-25 04:52:46 -0500 )edit

In my costmap_common_params.yaml file, here are the values I assigned: max_obstacle_height: 0.6 (in the folowing fields: gobal, obstacle layer, and scan) min_obstacle_height: 0.40 (in scan) origin_z: 0.1 (in obstacle_layer) z_resolution: 0.2 (in obstacle_layer) z_voxels: 2 (in obstacle_layer)

medjo gravatar imagemedjo ( 2017-07-25 03:53:14 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-03-15 05:10:52 -0500

t3m4 gravatar image

updated 2018-03-15 05:15:19 -0500

Since the Hokuyo's positioning and orientation do not match those of the Kinect, you will need to modify those parameters accordingly. If tweaking values for "max_obstacle_height", "min_obstacle_height" and "z_origin" don't work, increase the number of voxels the costmap uses.

Your default z_voxels value of 2 is like saying your map should only be 40 cm high (for z_resolution = 0.2), so if your Hokuyo origin is higher than that, it will be reported as out of bounds and the ray trace will not complete. Simply increasing z_voxels will fix the issue.

You could measure the height of your Hokuyo origin and set z_voxels accordingly, or just set it to 5 which tells the costmap to accept sensor origins within a 1 meter height.

edit flag offensive delete link more

Comments

Awesome, it worked ๐Ÿ˜€

R@m gravatar imageR@m ( 2018-03-15 05:59:05 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2016-07-20 08:55:15 -0500

Seen: 198 times

Last updated: Mar 15 '18