Ask Your Question
0

Post processing with rtabmap_ros and g2o.

asked 2016-07-18 10:29:58 -0600

necro gravatar image

updated 2016-07-21 04:27:34 -0600

Hello,

I'm trying to make post-processing with my acquired cloud (with Asus XtionPRO Live), following: https://github.com/introlab/rtabmap/w... I need it because my clouds are messy, there are much offset duplicates. My problem is that i can't even tick "Sparse Bundle Adjustment (SBA)", it's grey like odometry and source in preferences but in this cases I think because it's not stand-alone app. Does SBA is part of stand-alone app only?
I have g2o installed but I'm not sure if I did it correctly. G2o was downloaded from https://github.com/RainerKuemmerle/g2o and followed Compilation instructions without any problems, but I'm new to Linux (Ubuntu 16.04) and i did it on Desktop. Should rtabmap recognize It or i need to paste g2o-master somewhere? In Graph Optimization i can choose only TORO, g2o and GTSAM ale unavailable so I think there is something wrong with installation but it proceed without problems.
My other question is about parameters, does https://github.com/introlab/rtabmap/w... is still up to date? I can't turn off ICP as told there, I decided to use GFTT+FREAK should i change they params or left default?
If informations are incomplete I'm sorry it's my first question and I use RoS/Linux for few days and sometimes I get confused, I need to assembly few pieces in my mind about how it works ;)

[EDIT] I realized when camera stand on my desk Odometry "shake" - it moves a little in diffrent directions, is this normal or i configurate something wrong and that's why my clouds are sloppy?

Thanks for answers.

[Second Part]
Thanks for fast reply! You helped me a lot but now I met other problem.
I deleted binaries and installed rtabmap from source. Now it sees g2o and few other libraries which i had installed. Another problem is that now i can't Clear cache/Delete memory because rtabmapviz is crashing when i press one of those buttons. Other thing is that performance slow down voxles at rtabmapviz are much bigger than before and camera move slowly. Does that addition libraries slowed down mapping process (i think it's slower but better)? When installed binaries again so I can clear cache/delete memory but it still don't recognize g2o and other libraries it sees only OpenCV and works fast.
Is there any way to repair clearing cache (Is this necessary or can i clear it manually)? Can u tell me whether this slowdown is normal (addional Freenect, Openni2, g2o, Octomap)?
Below I put my console log.

[rtabmap/rtabmapviz-3] process has died [pid 13192, exit code -11, cmd /home/catkin_ws/devel/lib/rtabmap_ros/rtabmapviz -d -d /home/sky/catkin_ws/src/rtabmap_ros/launch/config/rgbd_gui.ini rgb/image:=/camera/rgb/image_rect_color depmage:=/camera/depth_registered/image_raw rgb/camera_info:=/camera/rgb/camera_info left/image_rect:=/stereo_camera/left/image_rect_color right/image_rect:=/stereo_camera/right/image_rect left/camera_info:=/stereo_camera/left/camera_info right/camera_info:=/stereo_camera/right/camera_info scan:=/scan scan_cloud ...
(more)
edit retag flag offensive close merge delete

Comments

You can disable the octomap from rtabmapviz by unchecking the related option in Preferences->Occupancy Grid Map -> Octomap.

matlabbe gravatar imagematlabbe ( 2016-07-21 05:59:11 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
3

answered 2016-07-18 13:59:49 -0600

matlabbe gravatar image

Post-processing stuff can be used in rtabmapviz too (must be Paused to be enabled). If g2o option is disabled, that means rtabmap library is not built with g2o. Make sure you are seeing -- With g2o = YES (License: BSD) when building rtabmap library:

$ cd rtabmap/build
$ cmake ..
(...)
-- Info :
--   Version : 0.11.8
--   CMAKE_INSTALL_PREFIX = /home/mathieu/catkin_ws/devel
--   CMAKE_BUILD_TYPE =     Release
--   CMAKE_INSTALL_LIBDIR = lib
--   BUILD_APP =            ON
--   BUILD_TOOLS =          ON
--   BUILD_EXAMPLES =       ON
--   BUILD_SHARED_LIBS =    ON
--   CMAKE_CXX_FLAGS =  -fmessage-length=0  -Wno-deprecated -fopenmp -std=c++11
--   With OpenCV 2 nonfree module (SIFT/SURF) = YES (License: Non commercial)
--   With Freenect             = YES (License: Apache v2 and/or GPLv2)
--   With OpenNI2              = YES (License: Apache v2)
--   With Freenect2            = NO (libfreenect2 not found)
--   With dc1394               = YES (License: LGPL)
--   With FlyCapture2/Triclops = NO (Point Grey SDK not found)
--   With TORO                 = YES (License: Creative Commons [Attribution-NonCommercial-ShareAlike])
--   With g2o                  = YES (License: BSD)
--   With GTSAM                = YES (License: BSD)
--   With VERTIGO              = YES (License: GPLv3)
--   With cvsba                = NO (cvsba not found)
--   With ZED                  = NO (ZED sdk not found)
--   With OCTOMAP              = YES (License: BSD)
--   With Qt4                  = YES (License: Open Source or Commercial)
-- --------------------------------------------
-- Configuring done
-- Generating done

The same info is also shown in the About dialog of rtabmapviz. You would also use g2o binaries from ros-kinetic-libg2o if you don't want to build from source g2o.

The camera is shaking because of the noise in the depth image. As you are using a Xtion, I recommend to stay up to 4 meters from objects/environments you are scanning. Far features have more noise, so odometry will shake more and will be less reliable.

The page https://github.com/introlab/rtabmap/w... is outdated. As mentioned at the top, most of these parameters are now used by default. ICP is not activated by default (it is now in Motion Estimation panel).

cheers

edit flag offensive delete link more

Comments

I got some more infomations rtabmapviz crash also when exporting map. Exported map looks fine but i can't post-process. When i restart rtabmapviz I can load database but when trying to download clouds: processRtabmapEvent3DMap() Map received with code error 1!
Low performance still not resolved

necro gravatar imagenecro ( 2016-07-20 07:08:07 -0600 )edit

Oh, i realized that slow performance was effect of Octomap library, i just unchecked Occupacy grid and it works fine! Crashing after saving is still little trouble for me.

necro gravatar imagenecro ( 2016-07-20 07:46:44 -0600 )edit

Octomap shown by default is a bug, it should not, it is now fixed.

matlabbe gravatar imagematlabbe ( 2016-07-20 15:13:27 -0600 )edit

Cannot reproduce the exporting/saving error. I am on ubuntu 14.04 Indigo.

matlabbe gravatar imagematlabbe ( 2016-07-20 15:19:12 -0600 )edit

Thanks for advice about using forum, i moved my question in right place. Today i will make clean install of Ubuntu 16.04 Xenial LTS and check if problem is solved.

necro gravatar imagenecro ( 2016-07-21 04:29:53 -0600 )edit

Still got random crashes after saving/clearing on clean install. I will try to prepare same configuration as You and check if there will be no errors. I made instructions list for myself, would You like to see it if I will translate it to English (already in Polish)?
PS. Saved maps are ok.

necro gravatar imagenecro ( 2016-07-21 08:57:13 -0600 )edit

After installing Ubuntu 14.04 and RoS Indigo random crashes gone. Thanks once again!

necro gravatar imagenecro ( 2016-07-25 05:29:31 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-07-18 10:02:02 -0600

Seen: 583 times

Last updated: Jul 21 '16