Ask Your Question
1

canopen chain node exit with error code -11 at start

asked 2016-07-15 21:33:53 -0500

I am trying to connect to an link[http://www.a-m-c.com/download/datasheet/dzcante-060l080.pdf "AMC DZCante 60L080"].

I know that I am connecting to the can bus as i can run socketcam_dump and see the drive's power on message. When I run the canopen_chain_node's chain the launch with the following yaml file:

bus:
      device: can0
     master_allocator: canopen::SimpleMaster::Allocator
sync:
     interval_ms: 5 
     overflow: 0
defaults:
     publish: ["1001sub0"]
nodes:
     node1: #Torso
     id: 42 
     name: Torso
     eds_file: '/robots/q1/axis1.eds'

I get the following the in logs:

[roslaunch][ERROR] 2016-07-15 22:06:38,132: [canopen_chain-1] process has died [pid 3572, exit code -11, cmd /opt/ros/indigo/lib/canopen_chain_node/canopen_chain_node __name:=canopen_chain __log:=/home/ocu/.ros/log/1371681c-4ac4-11e6-956c-001c23b398d6/canopen_chain-1.log].

The canopen_chain-1.log file does not exist so I am at loss on what to do next. I just want to establish basic communication with my drive. My overall goal is to connect my drive with ros control.

My help would be greatly appreciated. Thanks

edit retag flag offensive close merge delete

Comments

Have you try with a more basic config file? without the nodes and defaults field.

GuillaumeB gravatar imageGuillaumeB ( 2016-09-29 14:56:21 -0500 )edit

1 Answer

Sort by » oldest newest most voted
2

answered 2016-09-29 17:04:00 -0500

Mathias Lüdtke gravatar image

updated 2016-09-29 17:04:42 -0500

The released version is outdated, better try the source version. Please check the indention of your config, it looks a little bit shifted.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2016-07-15 21:33:53 -0500

Seen: 252 times

Last updated: Sep 29 '16