Ask Your Question
0 unable to read 32db.xml

asked 2016-07-05 05:59:08 -0500

jiashiwei gravatar image

3D lidar : HDL-64E S3 , ubuntu 14.04 indigo

when I operate the lidar HDL-64E S3 as the tutorial "" and run command "rosrun velodyne_pointcloud 32db.xml" , will appear as the following: converting "32db.xml" to "32db.yaml" unable to read 32db.xml

why ? I have checked that there is 32db.xml in the package.

someone can help me?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted

answered 2016-07-14 04:22:25 -0500

jiashiwei gravatar image

updated 2016-07-14 20:33:11 -0500

64db.xml can be found in the file calibration in stick member. the 64e_points.launch file can be got by just modifying 32e_points.launch

when run "rosrun velodyne_pointcloud 64db.xml" , should make the command run in the 64db.xml 's dictionary.

there are also two matters should be paid attention if want to make it work: a, make sure "sudo ifconfig eth0" succeed( chech it by "ifconfig -a",look at whether eth0 becomes There is a problem here: eth0 may not become "" after "sudo ifconfig eth0", I may do this several times(For the ifconfig issue , do “sudo ifdown eth0” and then after a few seconds do “sudo ifup eth0”. After change the interface config you may have to force it to read the new config changes by shutting it down and bringing it back up , and then the problem can be solved).

b, "roslaunch velodyne_pointcloud 64e_points.launch calibration:=/home/user/64db.yaml" "user" should be user's name, my user's name is exbot.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2016-07-05 05:59:08 -0500

Seen: 595 times

Last updated: Jul 14 '16