Rosmake: Command Not Found

asked 2016-07-02 21:50:00 -0600

Syngerical gravatar image

I'm trying to play a .wav sound file according to this tutorial http://wiki.ros.org/sound_play and when I try running "rosrun sound_play play.py /file/path", I get an error saying

[WARN] [WallTime: 1467513344.098907] Sound command issued, but no node is subscribed to the topic. Perhaps you forgot to run soundplay_node.py?

I think the reason that there is no node subscribed is because I never followed this tutorial http://wiki.ros.org/sound_play/Tutori... and never created the sound_play node. I got through the first line with rosdep but when I try to run rosmake on the second line, I get the error

rosmake: command not found

I'm not sure why this is so, I had this problem with roscd before but I fixed that by reinstalling ros-indigo. I tried that for this too, but it didn't work. I also tried reinstalling and updating rosdep but that didn't work either. My environment is sourced with "source devel/setup.bash". Any help would be appreciated and if you need more details, comment and ask below.

edit retag flag offensive close merge delete

Comments

Did you find a solution for this?

varunvp gravatar imagevarunvp ( 2018-02-21 00:11:53 -0600 )edit