Ask Your Question
0

Only with ROS - avrdude: stk500_recv(): programmer is not responding

asked 2016-06-25 14:17:39 -0500

Uncle_Jew gravatar image

I am having an issue with my Arduino using ros. I am using Ubuntu 14.04 with Jade.

When I upload the blink tutorial to my Arduino it works okay. But if as soon as I try adding #include <ros.h> or try to upload any of the ros_lib examples it errors out while trying to upload the sketch. Below are two screenshots showing the sucessful and unsucessful attempts. I searched for a few hours trying to find a solution but could not come to a solution.

image description image description

edit retag flag offensive close merge delete

Comments

It looks like it starts uploading fine, and then gets interrupted partway through the upload process. Setting up rosserial doesn't doesn't change the upload process, so this doesn't seem like an issue that could be caused by ROS.

ahendrix gravatar image ahendrix  ( 2016-06-25 19:26:28 -0500 )edit

Actually I take it back. After more testing it turns out not to be an issue only related to ROS. After your comment I did some more testing and other non ros examples are running into the same issue.

Uncle_Jew gravatar image Uncle_Jew  ( 2016-06-25 20:30:39 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-06-25 22:07:01 -0500

Uncle_Jew gravatar image

While it is not ideal I did come up with a temporary solution :/

I isolated the error to only happening in Ubuntu. Since it seems to be something there I decided to add the ros_lib folder on Windows and upload all my code there. Then run ROS in Virtualbox with Ubuntu. Would be nice to do it all through Ubuntu but as long as it is working I'm happy.

edit flag offensive delete link more
0

answered 2019-09-13 12:25:43 -0500

MrJake gravatar image

Mostly this type of error occurs due to these problems: 1. If Rx and Tx pins of arduino is connected with other device while uploading sketch. 2. If Port is not selected. 3. If your arduino is bricked. Solution for 1st two problem is easy just disconnect wires of Rx and TX pins and select port. But for 3 problem only solution is upload sketch using another arduino. I means SPI connection. For solution of 3rd Problem i will recommend you to read this article: Programmer is Not Respond Arduino

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-06-25 14:17:39 -0500

Seen: 507 times

Last updated: Jun 25 '16