ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

libpcan.h not found

asked 2016-06-16 19:28:54 -0600

jdcarp gravatar image

I have working code on an Ubuntu 14.04 VM that uses libpcan as a dependency. Everything runs great.

Now I am trying to build the same project on a fresh Ubuntu 14.04 partition. Suddenly libpcan is not recognized as a package.

I have tried to reinstall libpcan using rosdep

$ roscd libpcan
$ rosdep install libpcan
$ rosmake libpcan

However I cannot find the setup file to run after installing. I've since checked the directory found with

$ roscd libpcan

on both my VM and my partition, and they have the exact same contents: a cmake directory, and a package.xml.

Has anyone come across this issue?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2017-01-23 13:56:46 -0600

jdcarp gravatar image

This can be solved by downloading and installing the PeakCAN Linux drivers.

edit flag offensive delete link more

answered 2017-01-25 03:03:56 -0600

newbieros gravatar image

try to do it by synaptic package manager, it should look like thisimage description, I hope it works

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2016-06-16 19:28:54 -0600

Seen: 1,193 times

Last updated: Jan 25 '17