Ask Your Question
0

Building ROS on raspberry PI3

asked 2016-06-13 10:53:42 -0500

andrea-nisti gravatar image

Hello everyone.

I have followed the guide for building ROS on a rasberry and everything went fine. The only issue is that when i run catkin_make I encounter the following error:

Base path: /home/pi/catkin_ws
Source space: /home/pi/catkin_ws/src
Build space: /home/pi/catkin_ws/build
Devel space: /home/pi/catkin_ws/devel
Install space: /home/pi/catkin_ws/install
####
#### Running command: "cmake /home/pi/catkin_ws/src -DCATKIN_DEVEL_PREFIX=/home/pi/catkin_ws/devel -DCMAKE_INSTALL_PREFIX=/home/pi/catkin_ws/install -G Unix Makefiles" in "/home/pi/catkin_ws/build"
####
-- Using CATKIN_DEVEL_PREFIX: /home/pi/catkin_ws/devel
-- Using CMAKE_PREFIX_PATH: /opt/ros/indigo
-- This workspace overlays: /opt/ros/indigo
-- Using PYTHON_EXECUTABLE: /usr/bin/python
-- Using Debian Python package layout
-- Using empy: /usr/bin/empy
-- Using CATKIN_ENABLE_TESTING: ON
-- Call enable_testing()
-- Using CATKIN_TEST_RESULTS_DIR: /home/pi/catkin_ws/build/test_results
-- Found gtest sources under '/usr/src/gtest': gtests will be built
-- Using Python nosetests: /usr/bin/nosetests-2.7
CMake Error at catkin/cmake/assert.cmake:17 (message):


  Assertion failed: check for file existence, but filename
  (RT_LIBRARY-NOTFOUND) unset.  Message: RT Library

Call Stack (most recent call first):
  catkin/cmake/tools/rt.cmake:42 (assert_file_exists)
  catkin/cmake/all.cmake:147 (include)
  CMakeLists.txt:27 (include)


-- Configuring incomplete, errors occurred!
See also "/home/pi/catkin_ws/build/CMakeFiles/CMakeOutput.log".
See also "/home/pi/catkin_ws/build/CMakeFiles/CMakeError.log".

I am running raspbian jessie on a brand new raspberry pi 3. Does anyone knows what is happening?

If i run

sudo ./src/catkin/bin/catkin_make_isolated --install -DCMAKE_BUILD_TYPE=Release --install-space /opt/ros/indigo

the isolated build works but it takes ages. Is there a way to make the classic catkin_make work?

Thank you in advance,

Andrea

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-06-13 11:07:37 -0500

spmaniato gravatar image

To speed up compilation, create a 515MB or 1GB swap file or partition on the RPi3. It helps a lot.

edit flag offensive delete link more

Comments

Allright but I am looking on some forum and adding swap is not recomended as stated here: link text. Is that true? Moreover, there is some solution to the error I have after catkin make?

andrea-nisti gravatar image andrea-nisti  ( 2016-06-14 04:39:14 -0500 )edit

1) You can use dphys-swapfile, as recommended in the link you posted. It will help with compilation time. 2) I've never built the core ROS packages from source using catkin_make. I think they may have to be built in isolation (but I'm not as familiar with this)

spmaniato gravatar image spmaniato  ( 2016-06-14 08:54:12 -0500 )edit

Ok, thank you very much! I built the ros environment using catkin build instead and everything is fine now I guess. Still struggling in building mavros from source

andrea-nisti gravatar image andrea-nisti  ( 2016-06-14 10:39:44 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-06-13 10:53:42 -0500

Seen: 994 times

Last updated: Jun 13 '16