Ask Your Question
0

Unable to Contact my Own Server

asked 2016-06-08 10:59:06 -0500

Thalaiva gravatar image

updated 2016-06-08 12:24:39 -0500

I am trying to run a roslaunch but I am unable to. Here is the error message:

Unable to contact my own server at [http://host-ubuntu:37730/].
This usually means that the network is not configured properly.

A common cause is that the machine cannot ping itself.  Please check
for errors by running:

    ping host-ubuntu

For more tips, please see

    http://www.ros.org/wiki/ROS/NetworkSetup

The traceback for the exception was written to the log file

I tried to do ping host-ubuntu, but it returns ping: unknown host host-ubuntu, or in other words I am not getting any ping.

I tried to follow the directions in Unable to contact my own server where the asker has a similar problem, but this did not help me as I could not even find those two lines of code in my .bashrc to edit. Any help on this would be much appreciated, thank you!

Here is my .bashrc file as well for more context:

# ~/.bashrc: executed by bash(1) for non-login shells.
# see /usr/share/doc/bash/examples/startup-files (in the package bash-doc)
# for examples

# If not running interactively, don't do anything
case $- in
    *i*) ;;
      *) return;;
esac

# don't put duplicate lines or lines starting with space in the history.
# See bash(1) for more options
HISTCONTROL=ignoreboth

# append to the history file, don't overwrite it
shopt -s histappend

# for setting history length see HISTSIZE and HISTFILESIZE in bash(1)
HISTSIZE=1000
HISTFILESIZE=2000

# check the window size after each command and, if necessary,
# update the values of LINES and COLUMNS.
shopt -s checkwinsize

# If set, the pattern "**" used in a pathname expansion context will
# match all files and zero or more directories and subdirectories.
#shopt -s globstar

# make less more friendly for non-text input files, see lesspipe(1)
[ -x /usr/bin/lesspipe ] && eval "$(SHELL=/bin/sh lesspipe)"

# set variable identifying the chroot you work in (used in the prompt below)
if [ -z "${debian_chroot:-}" ] && [ -r /etc/debian_chroot ]; then
    debian_chroot=$(cat /etc/debian_chroot)
fi

# set a fancy prompt (non-color, unless we know we "want" color)
case "$TERM" in
    xterm-color) color_prompt=yes;;
esac

# uncomment for a colored prompt, if the terminal has the capability; turned
# off by default to not distract the user: the focus in a terminal window
# should be on the output of commands, not on the prompt
#force_color_prompt=yes

if [ -n "$force_color_prompt" ]; then
    if [ -x /usr/bin/tput ] && tput setaf 1 >&/dev/null; then
    # We have color support; assume it's compliant with Ecma-48
    # (ISO/IEC-6429). (Lack of such support is extremely rare, and such
    # a case would tend to support setf rather than setaf.)
    color_prompt=yes
    else
    color_prompt=
    fi
fi

if [ "$color_prompt" = yes ]; then
    PS1='${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\u@\h\[\033[00m\]:\[\033[01;34m\]\w\[\033[00m\]\$ '
else
    PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ '
fi
unset color_prompt force_color_prompt

# If this is an xterm set the title to user@host:dir
case "$TERM" in
xterm*|rxvt*)
    PS1="\[\e]0;${debian_chroot:+($debian_chroot)}\u@\h: \w\a ...
(more)
edit retag flag offensive close merge delete

Comments

Did you set the ROS_MASTER_URI to something?

dornhege gravatar imagedornhege ( 2016-06-08 11:27:23 -0500 )edit

No, where do I set that up, and what do I set it to?

Thalaiva gravatar imageThalaiva ( 2016-06-08 11:59:22 -0500 )edit

Now I'm getting this message when trying to roslaunch a package:

Invalid <arg> tag: environment variable 'ROS_HOSTNAME' is not set.

Arg xml is <arg default="$(env ROS_HOSTNAME)" name="machine"/>

Thalaiva gravatar imageThalaiva ( 2016-06-08 12:15:53 -0500 )edit
1

try to set ROS_IP and ROS_HOSTNAME to your computer up address

Maya gravatar imageMaya ( 2016-06-08 15:19:24 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-06-09 14:00:29 -0500

Sam94 gravatar image

If you are still having trouble connecting, you might try following the tutorials for setting up the network.

ROS/NetworkSetup: http://wiki.ros.org/ROS/NetworkSetup

ROS/Tutorials/MultipleMachines: http://wiki.ros.org/ROS/Tutorials/Mul...

They are relatively easy to follow and have some basic troubleshooting info.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-06-08 10:59:06 -0500

Seen: 3,304 times

Last updated: Jun 09 '16