Ask Your Question
0

Problems rqt_plot array

asked 2016-06-07 15:31:31 -0500

azul azul gravatar image

Hi!

I am trying to plot a topic /mytopic/taskSpace/position[0] using rqt_plot. My ROS version is Indigo and I have Ubuntu 14.

When I type in the console rostopic echo /mytopic/taskSpace/position[0] I can see the values, but when I make rosrun rqt_plot rqt_plot /mytopic/taskSpace/position[0] The values are not plot. Also there is not errors in the console. Even when I add again the same topic, the console shows PlotWidget.add_topic(): topic already subscribed: /mytopic/taskState/position[0]

I don't know how to solve this and it would be very usefull for me since I need to plot a lot of topic in order to check my code.

Than you so much!

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2016-06-09 02:31:21 -0500

azul azul gravatar image

I could find the solution. For someone with the same problem, it is necessary to fill the time stamp data in the message

msg.header.stamp = ros::Time::now()

edit flag offensive delete link more
1

answered 2018-01-30 05:44:32 -0500

Davide Faconti gravatar image

Additionally, you can use PlotJuggler: https://github.com/facontidavide/Plot...

There is an option, when you load a rosbag to either use the msg.header.stamp or the time when the message was received.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2016-06-07 15:31:31 -0500

Seen: 2,083 times

Last updated: Jan 30 '18