Ask Your Question
0

RTAB-Map rgbd_launch error Map received with code error 1! problem

asked 2016-06-01 10:12:35 -0500

Gabe gravatar image

updated 2016-06-01 18:44:34 -0500

matlabbe gravatar image

Hi, I am trying to use RTAB-Map on my clearpath Jackal robot (am reading its topics through the same wifi). I am not using OpenNI because my robot and ASUS Xtion rgbd camera have already been set up to publish the camera topics (as shown what i get after I type in rostopic list):

/camera/camera_nodelet_manager/bond
/camera/depth/camera_info
/camera/depth/image
/camera/depth/image_raw
/camera/depth/image_rect
/camera/depth/image_rect_raw
/camera/depth/points
/camera/depth_rectify_depth/parameter_descriptions
/camera/depth_rectify_depth/parameter_updates
/camera/depth_registered/camera_info
/camera/depth_registered/image_raw
/camera/depth_registered/image_raw/compressedDepth
/camera/depth_registered/points
/camera/depth_registered/sw_registered/camera_info
/camera/depth_registered/sw_registered/image_rect
/camera/depth_registered/sw_registered/image_rect_raw
/camera/driver/parameter_descriptions
/camera/driver/parameter_updates
/camera/ir/camera_info
/camera/ir/image
/camera/rectify_color/parameter_descriptions
/camera/rectify_color/parameter_updates
/camera/rgb/camera_info
/camera/rgb/image_raw
/camera/rgb/image_rect_color
/camera/rgb/image_rect_color/compressed

Whenever I run roslaunch rtabmap_ros rgbd_mapping.launch rtabmap_args:="--delete_db_on_start", it takes long for my RTAB to open up, and when it does run, I get the following on the Progress dialog of the RTAB GUI when I click on the Download all clouds button (looks like a refresh button) and I select any of the Options:

17:42:11 Downloading the map (global=false ,optimized=true)...
17:42:14 Downloading the map... done.
17:42:14 [ERROR] Map received with code error 1!

Meanwhile, the terminal keeps displaying:

[ WARN] [1464793454.065524286]: TF_OLD_DATA ignoring data from the past for frame camera_rgb_frame at time 1.46479e+09 according to authority unknown_publisher

Possible reasons are listed at http://wiki.ros.org/tf/Errors%20expla...

Anyone know how I might be able to fix this? Thanks for the help! :)

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-06-01 18:46:07 -0500

matlabbe gravatar image

I think I just answered the same question here.

cheers

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-06-01 10:12:35 -0500

Seen: 434 times

Last updated: Jun 01 '16