Ask Your Question
1

ROSARIA -- Impossible to Install

asked 2016-05-27 15:37:34 -0600

icepaka89 gravatar image

Please bear with me as I am getting increasingly frustrated with the immense difficulty of installing ROS and getting it working on my computer. It took DAYS to get ROS to even install correctly, and apt-get install ros-indigo-desktop-full would always exit with errors, every time. No forum posts helped me with this, but i DID manage to get it up and running after just building it from source. I still have to install ROSARIA and Gazebo, and I couldn't even get past the first few steps of the ROSARIA installation tutorial without being buried with errors and problems. I am still pretty new to Ubuntu and all of this is giving me real trouble, and actually helpful online solutions seem to be scarce for this software. Here's the basic rundown of my issues:

-I have tried to download ROSARIA from the website, and install it using Ubuntu Software. This does not even remotely work, I click install, nothing happens, nothing appears. -Next, I tried using rosdep install rosaria. I did this after I did apt-get update, apt-get upgrade, and resdep update. This gives me the same error every time:

ERROR: the following packages/stacks could not have their rosdep keys resolved to system dependencies: rosaria: No definition of [std_srvs] for OS version [xenial]

When I try to run catkin_make, it gets stopped by ROSARIA because of the following errors:

/home/icepaka89/catkin_ws/src/rosaria/LaserPublisher.cpp:5:25: fatal error: Aria/Aria.h: No such file or directory compilation terminated.

Can someone PLEASE help me figure this out, none of the other forum posts helped me and I really need to have this software installed by the end of today.

edit retag flag offensive close merge delete

Comments

Can you narrow down this question to one error in particular? (Though when you say "download ROSARIA... install using Ubuntu Software..." do you instead mean the ARIA library? If so what were the errors? What instructions are you using to install ROSARIA, were any steps of its tutorial unclear?

ReedHedges gravatar imageReedHedges ( 2016-05-31 16:17:05 -0600 )edit

Also if you are using http://wiki.ros.org/ROSARIA/Tutorials... and are using ROS Kinetic on Ubuntu 16.04, make sure to select the instructions for Kinetic. I've recently edited them to omit any instructions to use rosdep, since it won't work right now with Kinectic/16.04.

ReedHedges gravatar imageReedHedges ( 2016-05-31 16:19:58 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
5

answered 2016-05-27 16:23:33 -0600

daniel_dsouza gravatar image

updated 2016-05-27 16:36:52 -0600

Hello there,

You are not the only one having this problem today. I assume you are using Ubuntu 16.04, and therefore using Kinetic Kame?

To get the rosaria package to compile, here is what i did:

  1. I assume that you installed ROS using sudo apt install ros-kinetic-desktop-full
  2. I then downloaded the libaria_2.9.0+ubuntu12+gcc4.6_amd64.deb installation file from here
  3. Installed the .deb file with sudo dpkg -i libaria_2.9.0+ubuntu12+gcc4.6_amd64.deb
  4. went to /usr/local/Aria and ran make clean; make
  5. went to my catkin workspace and built the package with catkin build.

I was then able to source my workspace, and run the node with rosrun rosaria RosAria. I am unfortunately not able to test it, as I am quite far from my robot at the moment.

A few notes.

  • I tested this in a fresh 16.04 VM.
  • Regarding step 2, I also tried building the package from the source archive provided, but I was not able make install it. I was able to build the source as described in step 4.
  • Regarding step 4, you can speed up the build process with make clean; make -j16 where 16 is the number of threads you have.
  • Regarding step 5, I use catkin_tools which is a prettier and easier to use version of catkin. catkin_make should still work as well. I also assume that you have sourced your workspace script correctly (per the tutorials).
edit flag offensive delete link more

Comments

This totally fixed my problem!! You're a life saver thank you so much!! :)

icepaka89 gravatar imageicepaka89 ( 2016-05-27 18:00:45 -0600 )edit

Thank you very much. Your answer helps me a lot!

ROS_Fan gravatar imageROS_Fan ( 2016-05-28 12:49:36 -0600 )edit

Hi Daniel, curious what the reason you rebuilt aria in step 4... should normally not be needed (unless e.g. moving to different architecture.) Thanks.

ReedHedges gravatar imageReedHedges ( 2016-05-31 15:47:21 -0600 )edit

Note that libaria packages for 16.04 will be released sometime in the future, check back at robots.mobilerobots.com/wiki/Aria to see if they become available (will also be announced on aria-users list and news section of that site.)

ReedHedges gravatar imageReedHedges ( 2016-05-31 15:52:55 -0600 )edit

@ReedHedges if you install the .deb version, then it it installs libraries build with a old version of gcc (3.4 i think). When you build the rosaria package, the current compiler (5.3.1 for me) has trouble finding the libraries. After I rebuilt the libraries (w. 5.3.1), I was able to build rosaria.

daniel_dsouza gravatar imagedaniel_dsouza ( 2016-06-01 12:34:03 -0600 )edit

It worked for me. I have similar problems with my ROSAria instalation. I think ROSAria tutorial should heve been updated with this info.

Izwor gravatar imageIzwor ( 2016-07-24 13:52:38 -0600 )edit
1

Thanks I've put a note in the tutorial about rebuilding ARIA if you install the Ubuntu 12 package on Ubuntu 16. In GCC 5+ the standard library ABI has changed ( https://gcc.gnu.org/onlinedocs/libstd... ). There will be Ubuntu 16 packages at the next release of ARIA.

ReedHedges gravatar imageReedHedges ( 2016-07-25 09:00:47 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-05-27 15:37:34 -0600

Seen: 739 times

Last updated: May 27 '16