Ask Your Question
0

Problems building RosAria: errors with rosdep install libaria, and generating BumperState.msg code (em.Interpreter attribute not found in genmsg)

asked 2016-05-24 22:13:04 -0600

Horse-man gravatar image

updated 2016-06-09 20:45:03 -0600

Hello,

When trying to install RosAria in Kinetic Kame using

rosdep install rosaria

I got this error:

rosaria: No definition of [libaria] for OS version [xenial]

It seems, that RosAria team have not yet released the binaries for Ubuntu 16.04.

I tried instead to install from source, but, when I call catkin_make, I get the following message:

    Base path: /home/amine/catkin_ws Source space: /home/amine/catkin_ws/src Build space: /home/amine/catkin_ws/build Devel space: /home/amine/catkin_ws/devel Install space: /home/amine/catkin_ws/install
    ####
    #### 
Running command: "make cmake_check_build_system" in "/home/amine/catkin_ws/build"
    ####
    ####
    #### 
Running command: "make -j8 -l8" in "/home/amine/catkin_ws/build"
    #### 
[  0%] Built target std_msgs_generate_messages_nodejs
[  0%] Built target geometry_msgs_generate_messages_lisp 
[  0%] Built target geometry_msgs_generate_messages_nodejs 
[  0%] Built target std_msgs_generate_messages_py 
[  0%] Built target std_msgs_generate_messages_eus 
[  0%] Built target geometry_msgs_generate_messages_py 
[  0%] Built target geometry_msgs_generate_messages_eus 
[  0%] Built target _rosaria_generate_messages_check_deps_BumperState 
[  0%] Built target std_msgs_generate_messages_lisp 
[  0%] Built target std_msgs_generate_messages_cpp
[  9%] Built target rosaria_gencfg 
[  9%] Built target geometry_msgs_generate_messages_cpp 
[ 18%] Built target rosaria_generate_messages_nodejs 
[ 36%] Built target rosaria_generate_messages_py 
[ 54%] Built target rosaria_generate_messages_eus 
[ 63%] Built target rosaria_generate_messages_lisp 
[ 72%] Generating C++ code from rosaria/BumperState.msg Traceback (most recent call last):   File "/opt/ros/kinetic/share/gencpp/cmake/../../../lib/gencpp/gen_cpp.py", line 49, in <module>
        srv_template_map)   File "/opt/ros/kinetic/lib/python2.7/dist-packages/genmsg/template_tools.py", line 212, in generate_from_command_line_options
        generate_from_file(argv[1], options.package, options.outdir, options.emdir, options.includepath, msg_template_dict, srv_template_dict)  File "/opt/ros/kinetic/lib/python2.7/dist-packages/genmsg/template_tools.py", line 153, in generate_from_file
        _generate_msg_from_file(input_file, output_dir, template_dir, search_path, package_name, msg_template_dict)   File "/opt/ros/kinetic/lib/python2.7/dist-packages/genmsg/template_tools.py", line 98, in _generate_msg_from_file
        search_path)   File "/opt/ros/kinetic/lib/python2.7/dist-packages/genmsg/template_tools.py", line 76, in _generate_from_spec
        interpreter = em.Interpreter(output=ofile, globals=g, options={em.RAW_OPT:True,em.BUFFERED_OPT:True}) AttributeError: 'module' object has no attribute 'Interpreter' rosaria/CMakeFiles/rosaria_generate_messages_cpp.dir/build.make:63: recipe for target '/home/amine/catkin_ws/devel/include/rosaria/BumperState.h' failed make[2]: *** [/home/amine/catkin_ws/devel/include/rosaria/BumperState.h] Error 1 make[2]: *** Deleting file '/home/amine/catkin_ws/devel/include/rosaria/BumperState.h' CMakeFiles/Makefile2:2756: recipe for target 'rosaria/CMakeFiles/rosaria_generate_messages_cpp.dir/all' failed make[1]: *** [rosaria/CMakeFiles/rosaria_generate_messages_cpp.dir/all] Error 2 Makefile:138: recipe for target 'all' failed make: *** [all] Error 2 Invoking "make -j8 -l8" failed

EDIT: python --version

Python 2.7.11 :: Anaconda 4.0.0 (64-bit)

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2016-05-30 01:59:25 -0600

Horse-man gravatar image

Ok,

So finally, it was a conflict in python packages, it seems that both em and empy builds a package with the same name. So I just solved it by replacing em by empy:

pip uninstall em

pip install empy

Then I installed RosAria using the standard steps in the official RosAria documentation

edit flag offensive delete link more

Comments

Great! If you have time can you report this bug to genmsg, em and empy? If not let me know and I'll look into it more and report it. May I edit the title of this post to be more specifically about this Python package problem (and also the libaria installation as well.)

ReedHedges gravatar imageReedHedges ( 2016-05-31 15:49:05 -0600 )edit

Yes of course you can change the title. I reported the problem here, but I didn't dig deeper in genmsg code

Horse-man gravatar imageHorse-man ( 2016-05-31 22:52:08 -0600 )edit

I guess I can't change the title. I was going to change it to something like "Problems building RosAria: errors with rosdep install libaria, and generating BumperState.msg code (em.Interpreter attribute not found in genmsg)". If you change it that might help others find the solution to this problem

ReedHedges gravatar imageReedHedges ( 2016-06-09 09:01:32 -0600 )edit
1

answered 2016-05-25 09:28:24 -0600

ReedHedges gravatar image

updated 2016-05-25 09:29:57 -0600

You can just install ARIA from http://robots.mobilerobots.com/wiki/Aria. (The "Ubuntu 12 or Later" package will work fine.) Then don't use rosdep install rosaria, just run catkin_make (or catkin_make --force-cmake if necessary).

(Someone used to repackage libaria for each version of Ubuntu but they are not working on RosAria any more. Anyone is welcome to volunteer... or we will just switch back to manually installing libaria before building RosAria.)

edit flag offensive delete link more

Comments

P2OS is working on Kinetic if you want a temporary solution

https://github.com/allenh1/p2os.git

allenh1 gravatar imageallenh1 ( 2016-05-25 18:18:17 -0600 )edit

ok thanks @ReedHedges, your commit solved the first part (rosdep error), but still catkin_make --force-cmake still rise the error and don't create the executable of RosAria. I think the error now is about em package but this one is installed, and if I uninstall it, I get No module named em msg

Horse-man gravatar imageHorse-man ( 2016-05-25 22:08:18 -0600 )edit

This seems like a problem with Kinetic's genmsg or your installation. Seems to work fine for me, I've installed Kinetic from Ubuntu packages. Maybe make sure your ros-kinetic-genmsg package is up to date, or rebuild a new version from source if you're doing it that way?

ReedHedges gravatar imageReedHedges ( 2016-05-26 13:04:36 -0600 )edit

regarding a similar problem: ROSARIA -- Impossible to Install

daniel_dsouza gravatar imagedaniel_dsouza ( 2016-05-27 16:34:19 -0600 )edit

@ReedHedges updating genmsg and other packages didn't solve the problem, I even tried to reinstall ROS from source, and the problem with RosAria was the same @daniel_dsouza the problem looks similar, but even when I tried your steps, it was the same error when building catkin

Horse-man gravatar imageHorse-man ( 2016-05-30 01:40:55 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2016-05-24 22:13:04 -0600

Seen: 668 times

Last updated: Jun 09 '16