Ira_laser_tools error

asked 2016-05-19 05:57:03 -0600

aziz gravatar image

Hello every one i am using ira_laser_tools package to use two lasers but when i run the laserscan_multi_merger.launch i have this error

[pcl::concatenatePointCloud] Number of fields in cloud1 (5) != Number of fields in cloud2 (4)

anyone knows whers is the probleme and how solve it please

edit retag flag offensive close merge delete

Comments

hi aziz, I am also getting the same error. Did you manage to solve this error..? If so can you please share us the solution.

Regards,

GANESH gravatar imageGANESH ( 2018-03-26 05:18:05 -0600 )edit

hello,are you solve the problem?could you please give me some advice.

skydddive gravatar imageskydddive ( 2018-07-03 04:03:01 -0600 )edit

https://docs.ros.org/api/pcl_conversi... website is about ira_laser_merger.Your error is in this code,i think this website will help you.

skydddive gravatar imageskydddive ( 2018-07-03 21:59:21 -0600 )edit

I got the same problem. Any solution for this?

reno gravatar imagereno ( 2018-10-30 09:08:51 -0600 )edit
2

I had the same error. After looking at the scan data from the different laser scanners (hokuyo and rplidar), I found that one of my scanners were not publishing intensities as the device was not capable. I changed the .cpp file of the rplidar to stop publishing intensities and the ira node started working. Essentially, point cloud uses these intensities so the cloud data is different based on the intensity data.

Rishabh gravatar imageRishabh ( 2019-04-11 06:40:29 -0600 )edit