Ask Your Question
0

How to not use laser data for navigation?

asked 2016-05-12 10:35:24 -0500

mitch gravatar image

I'd like to prevent the local planner from using laser data, but I still want to publish it so that I can process it elsewhere. How can I do that?

edit retag flag offensive close merge delete

Comments

Can you show us your YAML files to see the parameters you use ?

Jbot gravatar image Jbot  ( 2016-05-13 02:16:02 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-05-12 23:58:27 -0500

robustify gravatar image

The easiest way to do that would be to set the occ_dist parameter of the local planner to zero (I assume you're using base_local_planner). This won't add any extra cost for potential trajectories to enter nonzero cost cells. I suppose you could even configure the local costmap to not have any layers, which would keep it empty.

I don't know your application, but you might find the robot will clip objects by doing something like this. The only way I see this working is if you update the global plan from navfn at a pretty high frequency.

I hope this helps!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-05-12 10:35:24 -0500

Seen: 60 times

Last updated: May 12 '16