Ask Your Question
0

[rospack] Error: package 'map_server' not found

asked 2016-04-29 07:12:50 -0600

wang cong gravatar image

updated 2016-05-01 22:14:11 -0600

I have used gmapping to build a map ,then I want to save the map: rosrun map_server map_saver . it prints: "[rospack] Error: package 'map_server' not found". Can someone help me?

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
7

answered 2016-04-30 03:14:22 -0600

Sounds like you have to run

sudo apt-get install ros-indigo-map-server

(assuming you're using ROS Indigo). If that doesn't help, there might indeed be a problem with your path setup and @TomSon's advice applies.

edit flag offensive delete link more

Comments

thanks.I used to run sudo apt-get install ros-indigo-map-server, but it prints: ros-indigo-map-server :Depends: libsdl-image1.2-dev but it is not going to be installed.I don't know how to do next?

wang cong gravatar image wang cong  ( 2016-05-02 01:58:22 -0600 )edit
3

This means you likely have some sort of package install/version conflict that normally does not appear on a clean Ubuntu install. Either google for "is not going to be installed" and learn how to resolve this, or perform a fresh install of Ubuntu.

Stefan Kohlbrecher gravatar image Stefan Kohlbrecher  ( 2016-05-02 02:14:10 -0600 )edit
1

Thanks. I use sudo aptitude install libsdl-image1.2-dev,and it works....Although I don't know why.

wang cong gravatar image wang cong  ( 2016-05-02 03:05:07 -0600 )edit

Ok, normally dependencies like this should be installed automatically, so there might still be an issue lingering. But you can probably ignore that for now :)

Stefan Kohlbrecher gravatar image Stefan Kohlbrecher  ( 2016-05-02 05:17:40 -0600 )edit

I am learning linux and ROS a little time ,so there maybe some problems.Thanks again

wang cong gravatar image wang cong  ( 2016-05-02 06:05:05 -0600 )edit

I tried to run sudo aptitude install libsdl-image1.2-dev and remove installed version, then re-install. It works ok

quannv gravatar image quannv  ( 2018-04-02 22:58:02 -0600 )edit
1

answered 2017-05-24 11:22:47 -0600

Gayan Brahmanage gravatar image

updated 2017-05-24 11:26:28 -0600

add this lines to your .bashrc

source /opt/ros/<ros-distro>/setup.bash

export ROS_PACKAGE_PATH=/home/<user>/catkin_ws:/opt/ros/<ros-distro>/share:/opt/ros/<ros-distro>/stacks

export ROS_WORKSPACE=/home/<user>/catkin_ws

for example

source /opt/ros/kinetic/setup.bash

export ROS_PACKAGE_PATH=/home/bgs/catkin_ws:/opt/ros/kinetic/share:/opt/ros/kinetic/stacks

export ROS_WORKSPACE=/home/bgs/catkin_ws

edit flag offensive delete link more
0

answered 2016-04-29 07:54:40 -0600

TomSon gravatar image

Check your source path. (normally in .bashrc) Check that you have installed and run rospack rosdep map_server (I use that to assure the dependencies)

edit flag offensive delete link more

Comments

Thanks. Please tell me more detail ,I am a newcomer in ROS . In my .bashrc,in the end of the file, "source /opt/ros/indigo/setup.bashsource ~/catkin_ws/devel/setup.bash",how to modify it?``

wang cong gravatar image wang cong  ( 2016-05-01 21:00:06 -0600 )edit

You don't have to modify it. I would recommend to start with a fresh install of Ubuntu 14.04 and use the One line install script. It will install all ROS properly.Then you can add the package map server.

TomSon gravatar image TomSon  ( 2016-05-02 13:32:11 -0600 )edit

Thanks.I have solved it.

wang cong gravatar image wang cong  ( 2016-05-04 01:45:30 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-04-29 07:12:50 -0600

Seen: 11,914 times

Last updated: May 24 '17