Ask Your Question
1

rosrun cannot find executables.

asked 2016-04-12 13:59:02 -0500

aland_t gravatar image

updated 2016-04-12 21:03:35 -0500

I realize this question has been asked to death, but when running rosrun raspicam raspicam_node I get the message [rosrun] Couldn't find executable named raspicam_node below /opt/ros/indigo/share/raspicam.

I am running Raspbian jessie on a Raspberry Pi 2 with ROS Indigo. catkin_make_isolated was used to build the workspace. I placed the following lines in .bashrc:

source /opt/ros/indigo/setup.bash export ROS_PACKAGE_PATH=/home/pi/ros_catkin_ws/src:/opt/ros/indigo/share:/opt/ros/indigo/stacks export ROS_WORKSPACE=/home/pi/ros_catkin_ws

Prior to running rosrun, I enter the ros_catkin_ws directory and input source devel_isolated/setup.bash The executable exists under ros_catkin_ws/devel_isolated/raspicam/lib/raspicam. If I move the executable to ros_catkin_ws/src/raspicam/src, everything works fine, but I would rather it work without manually moving files.

Output of echo $ROS_PACKAGE_PATH

Before sourcing: /home/pi/ros_catkin_ws/src:/opt/ros/indigo/share:/opt/ros/indigo/stacks

after sourcing: /home/pi/ros_catkin_ws/src/image_transport_plugins/theora_image_transport:/opt/ros/indigo/share:/opt/ros/indigo/stacks

edit retag flag offensive close merge delete

Comments

You can try source devel_isolated/setup.bash --extend instead. Without the extend flag, the last sourced file overwrites all of the previously loaded ones.

peci1 gravatar image peci1  ( 2016-04-12 18:08:34 -0500 )edit

If that does not help, please, edit your question and append the output of echo $ROS_PACKAGE_PATH after you source your workspace. And another thing - is the executable a Python script? If so, they have custom handling that allows you to run files directly from the source space.

peci1 gravatar image peci1  ( 2016-04-12 18:10:20 -0500 )edit

I added the output of echo echo $ROS_PACKAGE_PATH before and after sourcing. This is clearly a problem. The script is c++ not Python.

aland_t gravatar image aland_t  ( 2016-04-12 21:01:00 -0500 )edit

I think the .bashrc lines are not correct. Try source /opt/ros/indigo/setup.bash; source /home/pi/ros_catkin_ws/devel/setup.bash --extend; and do NOT manually set ROS_PACKAGE_PATH nor ROS_WORKSPACE. And also make sure you've built your workspace with catkin_make and try in a new terminal.

peci1 gravatar image peci1  ( 2016-04-13 08:18:49 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-04-13 11:58:57 -0500

aland_t gravatar image

The problem seems to have been fixed by putting the raspicam package in a separate workspace.

edit flag offensive delete link more

Comments

Haha , mahnnnn. Thanks for this .

Changing the workspace somehow fixed the problem .

Was breaking my head over it for over 2-3hours!

chrissunny94 gravatar image chrissunny94  ( 2018-06-25 08:07:22 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-04-12 13:59:02 -0500

Seen: 741 times

Last updated: Apr 13 '16