Ask Your Question
0

GMapping Performance differentiates between git package and sudo apt-get package

asked 2016-04-07 14:52:41 -0600

schultza gravatar image

updated 2016-04-08 03:23:11 -0600

Hi together,

Edit

See answer from myself.

Prolbem:

We are running Gmapping on our robot to map the environment but facing some really strange performance problems. (Dont be scared, I know it is an algorithm working a lot with probabilistics :) but that's not the problem ). Our problem is, Gmapping runs on our laptops pretty good, but not on our local pcs mounted to the robot which have better processors more RAM etc.. so overall a better performance

To our setup:

We recorded some bag files replayed them on a machine and run GMapping simultaneously. Everything works fine on our Thinkpad T450s with an i5 5300U and 8 Gigs RAM + SSD, Ubuntu 14.04. After round about 30 seconds the Thinkpad processed already 50 scans and updated the map.

Playing the same bag file with same setup, same launch file, everthing the same on our local machine on the robot which is a fanless ADLINK MXE5401 with an i7 4600EQ (which should be a little bit stronger compared to the thinkpads cpu, on a single core since GMapping has no multicore capabilities) 16GB RAM + SSD, Ubuntu 14.04, the GMapping is only capable of processing in round about 30seconds 10 Scans. So the algorithm detects "big jumps in odometry" and isn't able to match its environment/scans to the already built map anymore.

Maybe this is just a problem I never knew before about some cpu supoort by Ubuntu or anything else, maybe some of you guys can point me to the right direction.

Thanks in advance!!

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2016-04-08 03:48:43 -0600

gvdhoorn gravatar image

Could be that you didn't compile with -DCMAKE_BUILD_TYPE=Release or RelWithDebInfo. The binary packages are compiled with optimisations, which you otherwise don't get.

edit flag offensive delete link more

Comments

That did the trick!! Thanks so much!

schultza gravatar imageschultza ( 2016-04-08 04:27:51 -0600 )edit

Converted to answer for you.

gvdhoorn gravatar imagegvdhoorn ( 2016-04-08 04:45:19 -0600 )edit
0

answered 2016-04-08 02:43:57 -0600

schultza gravatar image

updated 2016-04-08 04:29:56 -0600

Problem seems to be solved.

My workspaces configuration was the problem: My workspace looked like this in the src folder:

If you use git clone as gvdhoorn mentioned you have to use following commands for building the packages: catkin_make -DCMAKE_BUILD_TYPE=Release

deleting openslam_gmapping package from workspace and installing it via sudo apt-get install ros-indigo-openslam-gmapping made the algorithm much much faster.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-04-07 14:52:41 -0600

Seen: 390 times

Last updated: Apr 08 '16