Ask Your Question
2

Can't install ROS on Raspberry Pi 3

asked 2016-04-06 12:21:08 -0600

jacksonkr_ gravatar image

I'm following this tutorial on how to install ROS on an ARM device.

Part of the problem is that Ubuntu 14.04 is not an install option for Raspberry Pi 3. What they support is Ubuntu MATE (15.04). Any ideas of how to get around this?

The error:

$ sudo apt-get install ros-indigo-ros-base
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ros-indigo-ros-base : Depends: ros-indigo-actionlib but it is not going to be installed
                       Depends: ros-indigo-bond-core but it is not going to be installed
                       Depends: ros-indigo-class-loader but it is not going to be installed
                       Depends: ros-indigo-dynamic-reconfigure but it is not going to be installed
                       Depends: ros-indigo-nodelet-core but it is not going to be installed
                       Depends: ros-indigo-pluginlib but it is not going to be installed
                       Depends: ros-indigo-ros-core but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
edit retag flag offensive close merge delete

Comments

1

If you get desperate, you could install ubuntu 14.04 within a chroot environment. http://wiki.ros.org/ROS/Tutorials/Ins...

John Hoare gravatar imageJohn Hoare ( 2016-04-06 12:27:39 -0600 )edit

3 Answers

Sort by ยป oldest newest most voted
4

answered 2016-04-06 12:39:11 -0600

ahendrix gravatar image

You can't install packages that are intended for 14.04 on a different version of Ubuntu. There will be version conflicts and missing dependencies.

There are already four other questions that address this issue. Perhaps one of their solutions will work for you?

http://answers.ros.org/question/23104...

http://answers.ros.org/question/23007...

http://answers.ros.org/question/22986...

http://answers.ros.org/question/22888...

edit flag offensive delete link more
1

answered 2016-06-27 00:10:53 -0600

audia8.sid gravatar image

Hello guys, I saw these posts recently and I too was trying to install not only ROS but also mavros on my new Raspberry Pi 3 but just like you guys, any of the wiki link did not work directly for me. So, I followed a combination of few steps from the above pages and also others and have documented everything in the PDF [link is below]. These steps worked for me and I was able to install ROS Kinect on Raspberry Pi 3.

Just to give a heads up- If you are trying to get ROS Indigo, you can only install a few individual packages as I tried or only ros-comm. If you want more features then I'm sorry ROS Indigo will not work on R-Pi3. You can try my steps and let me know if you face problems some where. It worked for me and believe me I spent a minimum 50+ hours figuring all this out!

link:[https://drive.google.com/open?id=0B4lNqhhSk7SQLVNZYzBZbm9mUG8]

edit flag offensive delete link more

Comments

Hey thanks for posting all your hard work up here! I ended up getting a Jetson TK1 so fortunately I was able to keep ROS Indigo.

jacksonkr_ gravatar imagejacksonkr_ ( 2016-06-27 09:07:37 -0600 )edit

Haha! no worries.. And great that you are not stuck there.

audia8.sid gravatar imageaudia8.sid ( 2016-06-27 20:27:30 -0600 )edit

Great work. I would love to follow your guide, but not being able to copy and paste the command lines from pdf makes it a lot harder.

elpidiovaldez gravatar imageelpidiovaldez ( 2016-10-01 20:32:31 -0600 )edit

Hi. I don't get why you are not being able to copy-paste the lines! You could download the file and should be able to do that. If not, can you elaborate what exactly is the problem you are facing or maybe email me, I can send you the doc file if you want. Let me know!

Cheers Sid

audia8.sid gravatar imageaudia8.sid ( 2016-10-01 21:15:33 -0600 )edit

hi @audia8.sid, thanks for your post. in my case is shows NO PACKAGE OGRE, OGRE-Overlay found. Please help. Error log: https://pastebin.com/NSwrJxcA

Ashkr gravatar imageAshkr ( 2019-11-03 21:22:13 -0600 )edit

Hi @Ashkr I haven't verified this for quite some time now but last I checked the ROS installation was pretty straight forward on RPi 3 with then latest Raspbian

audia8.sid gravatar imageaudia8.sid ( 2019-11-04 05:04:28 -0600 )edit

@audia8.sid, thanks for your reply! could you please check my error log related to 'rviz package failure' and correct me where I am mistaken? Also i am on Raspbian buster latest. Please guide! Thanks

Ashkr gravatar imageAshkr ( 2019-11-04 18:33:49 -0600 )edit

I am not sure; are you installing on a fresh/clean OS? And which version of ROS are you trying to install? Try following this wiki page which says it was last updated on 2019-09-26. It should help you install ROS on your RPi. For your particular error, it looks like some version error for something, a google search "No package 'OGRE' found" led me here. It says try to comment the line findOGRE in the cmake script. Hope this helps! Cheers

audia8.sid gravatar imageaudia8.sid ( 2019-11-04 19:23:42 -0600 )edit
0

answered 2016-04-06 12:27:35 -0600

you could build it on raspbian http://wiki.ros.org/ROSberryPi/Instal...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-04-06 12:21:08 -0600

Seen: 3,363 times

Last updated: Jun 27 '16