Ask Your Question

Connecting SICK TIM 571 via Ethernet to Ubuntu 14.04

asked 2016-04-05 15:21:11 -0500

Naman gravatar image

updated 2016-04-05 15:26:48 -0500


We're working on our robot running Ubuntu 14.04 and ROS indigo. Currently, we are trying to connect a Sick TIM 571 laserscanner via ethernet and the Ubuntu 14.04 tries to connect to the Ethernet but it keeps on failing and never connects to it. It works perfectly in Windows using the SOPAS Engineering Tool. Also I installed ROS drivers and when I run the following command : roslaunch sick_tim sick_tim571_2050101.launch, I keep on getting the following error :

[FATAL] [1459886892.692926805]: Could not resolve host: ... (1)(Host not found (authoritative))
[FATAL] [1459886892.693107727]: Failed to init device: 1
[ERROR] [1459886892.693164271]: sendSOPASCommand: socket not open

SOPAS - Error stopping streaming scan data!
sick_tim driver exiting.

I have also tried (from ):
"On edit connections, click add, go to ethernet tab, set device MAC address to the right ethernet port, got to IPv4 Settings tab, set method to Manual and enter these settings: Address: Netmask: Leave Gateway open and click save." but this also does not help in setting up the ethernet connection between SICK TIM 571 and Ubuntu 14.04.

I am not able to PING the sensor or anything because it is not even getting connected to the Ubuntu 14.04.
Does anyone know how can I set up the ethernet connection between SICK TIM 571 and Ubuntu 14.04?

Thanks in advance.
Naman Kumar

edit retag flag offensive close merge delete


Did you edit the sick_tim571_2050101.launch to enable TCP connection? Have you accidently changed the Tim's default IP address? Are you connecting the Tim directly to your Ubuntu or is a router/DHCP/switch between them?

JohnDoe2991 gravatar imageJohnDoe2991 ( 2016-04-06 00:50:04 -0500 )edit

If you haven't changed the default IP address and you connect the TIM directly to your Ubuntu, you need to set a static IP address in Ubuntu to, because conflicts with the default Tim IP address

JohnDoe2991 gravatar imageJohnDoe2991 ( 2016-04-06 00:52:07 -0500 )edit

Yeah.. I did edit the sick_tim571_2050101.launch.. and I am connecting TIM directly to the Ubuntu. Yeah.. I think it is some IP conflict issue. How can I set a static IP address in Ubuntu to Thanks in advance.

Naman gravatar imageNaman ( 2016-04-06 12:39:58 -0500 )edit

Take only Step 1 from this HowTo and then restart your system. You don't need to add the gateway line.

JohnDoe2991 gravatar imageJohnDoe2991 ( 2016-04-06 13:55:58 -0500 )edit

@Naman have you resolved your issue. And can you tell me how ? i have the similar issue as yours

hashim gravatar imagehashim ( 2016-07-26 07:44:13 -0500 )edit

1 Answer

Sort by » oldest newest most voted

answered 2016-04-18 03:54:27 -0500

Maybe this issue will help you: sick_tim #34.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2016-04-05 15:21:11 -0500

Seen: 1,864 times

Last updated: Apr 18 '16