Ask Your Question
2

No costmap in local map [closed]

asked 2016-03-22 23:31:28 -0600

lightbulb gravatar image

updated 2016-03-25 15:35:46 -0600

Hello all,

Recently, I use Raspberry Pi 2, iRobot Create 1 and XV-11 to build up an autonomous navigation robot. My robot can navigate itself with pre-established map, but I still have a problem with it.

I get no costmap in local map section. I use the same parameters with turtlebot_navigation demo. It means that although my robot can avoid walls, doors and other static obstacles with amcl and map, it can not avoid temporary obstacles, such as people and trash bin which is not in the original map. I saw some videos on Youtube that others use this same approach, but they can get the local costmap. I don't know why about this issue. I tried to get topic message from the local costmap topic, but there are all zero values in the message.

Here is the screenshot of my rviz when running amcl:

image description

And this is the nodes graph of my program:

image description

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by lightbulb
close date 2016-04-07 15:50:43.439640

Comments

Are you sure that when you echo local cost map, all the values are zero? If so, can you check the observation sources of the local cost map( by running rosparam get /move_base/local_costmap/obstacle_layer/observation_sources )?

DavidN gravatar imageDavidN ( 2016-03-27 20:41:01 -0600 )edit

I'm having the same problem as of VERY recently. Up until a few weeks ago the local costmap was working just fine. Now it's all zeros even though the observation sources did not change. Edit: see my answer

spmaniato gravatar imagespmaniato ( 2016-04-06 16:35:13 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2016-04-06 17:05:00 -0600

spmaniato gravatar image

I had the same problem, but when simulating a robot using Stage. In my case, the culprit turned out to be a mistake in my Stage world model, which made the height of the LiDAR sensor be 0.502 (twice what it should be, 0.251). In turn, this made the LiDAR measurements' height be outside the bounds of my obstacle layer's observation source:

min_obstacle_height: 0.0
max_obstacle_height: 0.5

Thus, the local costmap was all zeros because it was reflecting the wrong height. Once I "lowered" my LiDAR to the correct height, the local costmap worked as expected.

edit flag offensive delete link more

Comments

You are right, thank you!

lightbulb gravatar imagelightbulb ( 2016-04-07 15:32:21 -0600 )edit

Awesome, glad I could help! Could you please also mark my answer as correct by clicking on the checkmark icon to the left? (right below the vote up/down buttons)

spmaniato gravatar imagespmaniato ( 2016-04-07 15:50:30 -0600 )edit

Question Tools

2 followers

Stats

Asked: 2016-03-22 23:31:28 -0600

Seen: 1,288 times

Last updated: Apr 06 '16