Installing ros-java on Ubuntu wili

asked 2016-03-21 00:51:44 -0600

updated 2016-03-21 02:43:45 -0600

gvdhoorn gravatar image

I am trying to install ros java from source on ubuntu wili

I am following the link: http://wiki.ros.org/rosjava/Tutorials...

But when it come to:

rosdep install --from-paths src -i -y

I get error this message:

rocon_rosjava_core: No definition of [rocon_interaction_msgs] for OS version [wily]
rosjava_build_tools: No definition of [ant] for OS version [wily]
rosjava_messages: No definition of [move_base_msgs] for OS version [wily]

So I decided to install these packages from source also, my question is:

How can I install these packages from source, I searched a lot of wiki pages but it seems the information is scattered or I am missing something.

I understand that I can download the whole package stack, and I did that, for example, move_base_msgs is in navigation stack, i have downloaded it but i have no idea how I can install it and make the output of the installation to be in /opt/ros/indigo.

edit retag flag offensive close merge delete