Ask Your Question
0

catkin_make error: invoking "cmake" failed

asked 2016-03-19 01:24:31 -0500

Fuzzball gravatar image

updated 2016-03-19 07:26:45 -0500

I'm on ubuntu 14.04 I'm using ROS indigo. I am new to ROS. I know there are similar questions on here but their answers didn't help me.

I've been following some ROS/catkin tutorials and am currently on this one: http://wiki.ros.org/catkin/Tutorials/... .

The instructions all worked fine until I got to catkin_make. Roscore was running in a separate terminal at the time.

I took a snapshot of the error and was going to upload it but apparently I don't have enough points. (If you want to teach newbies to write questions in an easy-to-follow way, it'd be useful to allow them to upload screenshots.)

I uploaded the screenshot to photobucket instead:

image description

edit retag flag offensive close merge delete

Comments

2

[..] it'd be useful to allow them to upload screenshots.

Personally I'd rather ppl copy/paste the console text, as it is then indexed by search engines, whereas images are not. Also: img hosts have different retention policies, which can lead to screenshots disappearing.

gvdhoorn gravatar image gvdhoorn  ( 2016-03-19 02:24:22 -0500 )edit

I'm on windows 8.1 [..]

Can you please tell us how you installed ROS, which VM product you are using and what arch this is?

gvdhoorn gravatar image gvdhoorn  ( 2016-03-19 02:29:15 -0500 )edit

I'm not sure what a VM product is or what an arch is. I just realized that windows 8.1 was incorrect (I got confused cos this computer has two operating systems), I'm using ROS on Ubuntu 14.04. I installed ROS by following the steps in this link: http://wiki.ros.org/indigo/Installati...

Fuzzball gravatar image Fuzzball  ( 2016-03-19 07:26:20 -0500 )edit

VM == virtual machine, arch == processor architecture. As you reported you were running Windows 8.1, the only way to have ROS running would be in a virtual machine, hence my question.

gvdhoorn gravatar image gvdhoorn  ( 2016-03-19 08:51:21 -0500 )edit

Hi.I have met the same situation. Have you solved it yet? Thanks for your help.

ross123 gravatar image ross123  ( 2016-06-16 03:38:51 -0500 )edit
tobinfinity gravatar image tobinfinity  ( 2017-06-06 14:23:41 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-03-08 12:05:58 -0500

Rai gravatar image

Hi,

try:

$ echo $ROS_PACKAGE_PATH

to see a list of paths, you should see something like:

/opt/ros/indigo/share:/opt/ros/indigo/stacks

If not, probably you have placed a new path to your ~/.bashrc . Simply remove it and it should work.

Type:

$ sudo gedit ~/.bashrc

a file will open, scroll all the way down and remove the last one(s), save and exit. Try in a new terminal.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-03-19 01:24:31 -0500

Seen: 3,930 times

Last updated: Mar 08 '17