Ask Your Question
0

How to let robot_pose_ekf recieve IMU data from gazebo

asked 2016-03-17 03:25:56 -0600

Hi all,

I'm using robot_pose_ekf with gazebo simulator.

Now, I've encountered with a problem that the /robot_pose_ekf only takes in /odom while the IMU data is not transferred.

To be more detailed, /gazebo published IMU data as topic: /mobile_base/sensors/imu_data [sensor_msgs/Imu]. However, /robot_pose_ekf didn't subscribe this topic, instead it listen to /imu_data which has no publisher! I feel it so strange and cannot understand it at all.

Can anyone tell me how to let /robot_pose_ekf subscribe the right topic from /gazebo? FYI, in the launch file of /robot_pose_ekf I tuned "odom_used" "imu_used" to "true" and "vo_used" to "false".

Any hints are welcome.

Thank you in advance.

Clack

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
2

answered 2016-03-17 05:22:22 -0600

Captcha gravatar image

did you try to remap /mobile_base/sensors/imu_data -> /robot_pose_ekf ?

http://wiki.ros.org/roslaunch/XML/remap

edit flag offensive delete link more

Comments

It works! Thank you so much!

But to be more precise, the command to be added in robot_pose_ekf.launch should be:

<remap from=”imu_data” to=”mobile_base/sensors/imu_data”/>

:)

Clack gravatar imageClack ( 2016-03-17 06:02:26 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-03-17 03:25:56 -0600

Seen: 421 times

Last updated: Mar 17 '16