Ask Your Question
0

Kobuki Left Bumper stuck

asked 2016-03-13 12:29:52 -0500

jseal gravatar image

updated 2016-03-14 09:06:27 -0500

My Kobuki left bumper has somehow gotten stuck, I could probably live with this, but it messes up the auto_docking node, which reports feedback: [dockdrive: bumped]: and my robot just backs up.

I've verified the behavior by running the following commands in order.

  • roscore
  • rostopic echo /mobile_base/events/bumper
  • roslaunch kobuki_node minimal.launch --screen

As soon as the kobuki_node comes up the echo report the following below. Also, the right and center bumper work as expected.

bumper: 0
state: 1

Pressing the left bumper has no effect on the echo command above. Ie. the Kobuki think the left bumper is always pressed. So I have two options:

Option 1: Find some documentation on how to take the bumper off and see why it's stuck.

Option 2: Get the auto_docking node to work despite the left bumper being stuck.**

Any ideas?

Thanks

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-03-22 22:57:59 -0500

jseal gravatar image

If you take a flat head screw drive and slide it into the opening on the side of the bumper, you can then pry up enough to see a white contact switch with a flashlight (be very carefully). A second screw driver can then be used to unfree the stuck bumper.

With the bumper not stuck the auto dock routine works perfect.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2016-03-13 12:29:52 -0500

Seen: 99 times

Last updated: Mar 22 '16