Ask Your Question
0

package 'libopenni' not found - OPENNI_INCLUDE_DIRS problems

asked 2016-03-13 05:08:31 -0500

MarkyMark2012 gravatar image

Hi All,

I am slowly making progress towards getting laser_scan_matcher installed on rasp pi.

I have all the pcl dependencies complied

Problem I am now faced with a dependency when compiling the laser_scan_matcher itself. I've build openni and installed it but catkin_make is giving the following errors - even though I've exported the dir's for OPENNI_INCLUDE_DIRS

-- +++ processing catkin package: 'scan_to_cloud_converter'
-- ==> add_subdirectory(scan_tools/scan_to_cloud_converter)
-- Using these message generators: gencpp;genlisp;genpy
-- checking for module 'libopenni'
--   package 'libopenni' not found
-- Could NOT find openni (missing:  OPENNI_INCLUDE_DIRS)
-- The imported target "vtkWrapTcl" references the file
  "/usr/bin/vtkWrapTcl"
but this file does not exist.  Possible reasons include:
* The file was deleted, renamed, or moved to another location.
* An install or uninstall procedure did not complete successfully.
* The installation package was faulty and contained
"/usr/lib/vtk-5.8/VTKTargets.cmake"
but not all the files it references.

Anyone any ideas?

Thanks

Mark

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-05-29 04:04:53 -0500

stu70048 gravatar image

sudo apt-get install libopenni-dev

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-03-13 05:08:31 -0500

Seen: 342 times

Last updated: Mar 13 '16