Ask Your Question

Unsupported depth video mode - Asus Xtion Pro with openni2.launch

asked 2016-03-04 08:29:24 -0500

gavran gravatar image

updated 2016-03-06 03:25:34 -0500

I have Asus Xtion Pro (1d27/0601) and try to launch openni2.launch (from openni2_launch package). I get the following error:

Unsupported depth video mode - Resolution: 1280x1024@15Hz Format: Depth 1mm

Interestingly, with openni.launch everything works smoothly. WHat could be the problem with openni2? Alternatively, is there an option to tell other packages to work with openni? (for example, 3dsensor.launch from turtlebot_bringup package)

UPDATE: the solution was in restarting everything (including roscore) - pay attention to comment section under the accepted answer.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2016-03-04 09:04:11 -0500

updated 2016-03-07 06:32:45 -0500

AS fare I know your sensor supports VGA@30fps or QVGA@60fps for the depth image. And even this resolution is not the effective resolution of the sensor.

If you have a bad configuration, e.g. you set a wrong resolution with dynamic reconfiguration, you may restart roscore. Many configuration in ROS are stored in the parameter server and it runs inside of the ROS master. Due to this the configuration persists as long the roscore runs.

edit flag offensive delete link more


I am still confused: why at all does openni2 complain about resolution? I didn't set any specific resolution. Is it reading it from some config file for sensor?

gavran gravatar image gavran  ( 2016-03-04 09:40:45 -0500 )edit

Did you a fresh start of openni2.launch without any arguments? "fresh" means to restart roscore, too.

MichaelKorn gravatar image MichaelKorn  ( 2016-03-04 09:49:17 -0500 )edit

after restarting roscore, suddenly everything works! thanks for the suggestion. do you have any idea what could cause the trouble? Please, add the suggestion of restarting roscore in the answer, and I'll accept so that it can be useful for others as well

gavran gravatar image gavran  ( 2016-03-04 11:25:56 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2016-03-04 08:29:24 -0500

Seen: 616 times

Last updated: Mar 07 '16