Ask Your Question
0

Issues staring tf/static_transform_publisher for neato XV-11

asked 2016-02-25 04:03:22 -0500

jaymo3141 gravatar image

I am running the following launch file on my Raspberry Pi Indigo installation.

<?xml version="1.0"?>

<launch>
  <node pkg="xv_11_laser_driver" type="neato_laser_publisher" name="xv_11_node">
    <!--<param name="port" value="/dev/tty.usbserial-A9UXLBBR"/>-->
    <param name="port" value="/dev/ttyUSB0"/>
    <param name="firmware_version" value="2"/>
    <param name="frame_id" value="laser"/>
  </node>
  <node pkg="tf" type="static_transform_publisher" name="base_frame_2_laser" ar$

</launch>

But I am getting the following error

ERROR: cannot launch node of type [tf/static_transform_publisher]: tf

ROS path [0]=/opt/ros/indigo/share/ros

ROS path [1]=/opt/ros/indigo/share

ROS path [2]=/opt/ros/indigo/stacks

I have tried to build the tf package from source by cloning the git repository into "catkin_ws/src/tf" and running catkin_make from "~/catkin_ws" which is my workspace.

I am a ROS beginner and I'm having a lot of trouble getting this to work.

Thank you for you help

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-03-02 18:17:54 -0500

spmaniato gravatar image

Once you've fixed the tf installation issue, here's how to properly run a static_transform_publisher from your launch file:

  <node pkg="tf" type="static_transform_publisher" name="base_frame_2_laser"
  args="0 0 0.05 0 0 0 1 /base_link /laser 50" />

Here I've assumed that the LiDAR is attached at z = +5cm and its orientation is the same as the robot's base link. The number 50 is the publishing rate, which could be lower.

edit flag offensive delete link more
0

answered 2016-03-01 01:33:34 -0500

mgruhler gravatar image

ROS is only looking for tf in the folders specified in your error output. It should work, if you have installed tf as a debian package. Check with dpkg -s ros-indigo-tf

If you want to launch the one built from source, you need to source your catkin workspace. I.e. in every terminal do a source ~/catkin_ws/devel/setup.bash (you can add this to your .bashrc for having it done automatically).

edit flag offensive delete link more

Comments

running dpkg -s ros-indigo-tf indicates that the package is not installed. How do I install it?

jaymo3141 gravatar imagejaymo3141 ( 2016-03-01 20:38:26 -0500 )edit

Either install as debian package sudo apt-get install ros-indigo-tf or from source. See the ROS wiki how to do this.

If you are running UbuntuARM, you might need to check this page

mgruhler gravatar imagemgruhler ( 2016-03-02 00:57:46 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2016-02-25 04:03:22 -0500

Seen: 728 times

Last updated: Mar 02 '16