Ask Your Question
0

how to run ros on raspberry-pi and another machine

asked 2016-02-21 05:49:41 -0500

Moon gravatar image

updated 2016-02-21 07:58:58 -0500

gvdhoorn gravatar image

I want to run a talker node on my ubuntu and subscriber "listener node " on raspberry pi on raspbian I already set the ROS_MASTER_URI to the ip of my raspberry pi and nodes are run correctly but it doesn't subscribe anything :\

this is my roswtf output

Loaded plugin tf.tfwtf
No package or stack in context
================================================================================
Static checks summary:

Found 1 error(s).

ERROR Not all paths in PYTHONPATH [/home/ubuntu/catkin_ws/devel/lib/python2.7/dist-packages:/opt/ros/indigo/lib/python2.7/dist-packages] point to a directory: 
 * /home/ubuntu/catkin_ws/devel/lib/python2.7/dist-packages

================================================================================
Beginning tests of your ROS graph. These may take awhile...
analyzing graph...
... done analyzing graph
running graph rules...
ERROR: Unknown host [raspberrypi] for node [/rosout]
... done running graph rules

Online checks summary:

Found 1 warning(s).
Warnings are things that may be just fine, but are sometimes at fault

WARNING The following node subscriptions are unconnected:
 * /rosout:
   * /rosout


Found 2 error(s).

ERROR Could not contact the following nodes:
 * /rosout

ERROR Errors connecting to the following services:
 * service [/rosout/get_loggers] appears to be malfunctioning: Unable to communicate with service [/rosout/get_loggers], address [rosrpc://raspberrypi:33201]
 * service [/rosout/set_logger_level] appears to be malfunctioning: Unable to communicate with service [/rosout/set_logger_level], address [rosrpc://raspberrypi:33201]
edit retag flag offensive close merge delete

Comments

Can you provide more information. Which machine are you running roscore on, have you run roswtf, what does rqtgraph show you when you run it

nickw gravatar imagenickw ( 2016-02-21 05:53:26 -0500 )edit

I have my laptop with ubuntu and raspberry pi with raspbian .. roscore running on raspberry pi .. I export ROS_MASTER_URI as pi roscore for my laptop and pi ,when I run talker node on my laptop it run correctly and a listener node run correctly too on raspberry pi but it doesn't listen to the talker

Moon gravatar imageMoon ( 2016-02-21 06:05:33 -0500 )edit

I updated my question with the roswtf output

Moon gravatar imageMoon ( 2016-02-21 06:13:59 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-02-21 06:23:57 -0500

NEngelhard gravatar image

Most probably, you are not setting the ROS_IP (or ROS_HOSTNAME): http://wiki.ros.org/ROS/EnvironmentVa...

edit flag offensive delete link more

Comments

yes it was the problem ..thanks :) and it is explained here http://answers.ros.org/question/18804...

Moon gravatar imageMoon ( 2016-02-21 08:10:41 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-02-21 05:49:41 -0500

Seen: 710 times

Last updated: Feb 21 '16