Ask Your Question
1

How to send right velocity to model in gazebo?

asked 2016-02-16 11:55:46 -0500

cybodroid gravatar image

Hi, I am sending velocity command to gazebo model but it only reflects 35% of commanded velocity. I tried to tune PID gain in config file but it doesn't affect anything. In xacro file also, changing mechanical reduction doesn't seem to work. Does anybody have idea how to fix it so that I can get the velocity what I am commanding to the model?

Thanks.

edit retag flag offensive close merge delete

Comments

Please give us more information on what node are you using. If you use a ros controller maybe the config from cmd_vel to hardware is wrong. If you use directly a gazebo controller maybe their is a transmission gearing down the speed

Arowana gravatar imageArowana ( 2016-02-16 20:00:23 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-02-18 02:21:39 -0500

cybodroid gravatar image

I am using latter approach. I can say that transmission is the culprit. But changing the mechanicalReduction is not doing anything.

edit flag offensive delete link more
0

answered 2016-02-16 14:06:31 -0500

Devin gravatar image

Maybe the model has Maximum speed.

edit flag offensive delete link more

Comments

Model has maximum speed limit of 10 m/s. But It doesn't matter if I send 3 m/s or 1 m/s or 15 m/s . It is always approximately 35% of the input velocity and I am not able to figure out how to fix it.

cybodroid gravatar imagecybodroid ( 2016-02-16 14:24:27 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-02-16 11:55:46 -0500

Seen: 239 times

Last updated: Feb 16 '16