Ask Your Question
0

Dependencies for Hector_Slam

asked 2016-02-11 06:10:21 -0500

papaclaudia gravatar image

Hi! I'm trying to install hector_slam on a Raspberry Pi 2 (it has ROS Indigo Comm). I would follow the steps listed but I do not know what other dependencies to add it because at the end of catkin_make I have an error. How do I know what dependencies will be needed? Can I install ROS Indigo Desktop on RPi 2? Thank you!

$ cd ros_catkin_ws/src
$ git clone https://github.com/tu-darmstadt-ros-pkg/hector_slam.git
$ sudo apt-get install *******WHAT DEPENDENCIES WILL BE NEEDED?*******
$ cd ..
$ catkin_make
$ source devel/setup.bash
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2016-02-12 02:05:09 -0500

What @mig says. Also, if you installed ROS from .debs on your RPi2 you can just run

   sudo apt-get install ros-indigo-hector-slam

for installing precompiled binaries.

edit flag offensive delete link more

Comments

hmpf, forgot about the easy one ;-) +1

mgruhler gravatar image mgruhler  ( 2016-02-12 02:23:20 -0500 )edit
0

answered 2016-02-12 01:45:44 -0500

mgruhler gravatar image

You can use rosdep to resolve the dependencies. See here. Check out the wiki page on how to install and initalize it properly

rosdep install -i --from-paths <PATHTOSRCFOLDER>

Basically, it checks the package.xml of the ROS packages and installs the respective dependencies.

If you do a check instead of install, it shows you which dependencies are not installed correctly. However, note that this depends on the dependencies being specified properly in the package.xmls.

So you might run into some problems as well.

(I just hope this works an a RPi2 as well ;-) )

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-02-11 06:10:21 -0500

Seen: 232 times

Last updated: Feb 12 '16