Ask Your Question
0

RTABMAP localization with turtlebot issue

asked 2016-02-01 09:52:21 -0500

kaygudo gravatar image

updated 2016-02-04 09:52:50 -0500

matlabbe gravatar image

Hello,

As instructed in the tutorial Mapping and Navigation with Turtlebot after mapping "$ roslaunch rtabmap_ros demo_turtlebot_mapping.launch args:="--delete_db_on_start" rgbd_odometry:=true"

for localization when i try to execute the command " $ roslaunch rtabmap_ros demo_turtlebot_mapping.launch localization:=true" .

i get following error:

[ INFO] [1454339969.590369016]: rtabmap 0.10.10 started...

[ INFO] [1454339970.864339986]: Stopping device RGB and Depth stream flush.

[ WARN] [1454339972.332150185]: Timed out waiting for transform from base_footprint to map to become available before running costmap, tf error: Could not find a connection between 'map' and 'base_footprint' because they are not part of the same tree.Tf has two or more unconnected trees.. canTransform returned after 0.100846 timeout was 0.1.

[ WARN] [1454339974.865176406]: rtabmap: Could not get transform from odom to base_footprint after 0.100000 second!

[ WARN] [1454339974.995544194]: rtabmap: Could not get transform from odom to base_footprint after 0.100000 second!

and this goes on....

what's the issue? please guide me i am new to ROS.

Thank you

edit retag flag offensive close merge delete

Comments

Error missing?

Humpelstilzchen gravatar image Humpelstilzchen  ( 2016-02-02 02:17:16 -0500 )edit

due to some reason the error message is not shown here. do u know why?

kaygudo gravatar image kaygudo  ( 2016-02-02 23:06:26 -0500 )edit

sorry no, maybe try pastebin

Humpelstilzchen gravatar image Humpelstilzchen  ( 2016-02-03 11:10:54 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-02-04 10:00:10 -0500

matlabbe gravatar image

Hi,

On your second call, the visual odometry node is not started, so it is why rtabmap is complaining that there is no odometry TF between /odom and /base_footprint. Try this instead:

$ roslaunch rtabmap_ros demo_turtlebot_mapping.launch localization:=true rgbd_odometry:=true

Note that if you are on the actual robot, you may want to use the odometry TF/topic from turtlebot.

cheers

edit flag offensive delete link more

Comments

Thanks! that worked.But after done with mapping, when i proceeded for localization and typed the command as mentioned above by you and in http://wiki.ros.org/rtabmap_ros/Tutor... localization mode, nothing happens, as mentioned in the link a 2d map should reappear.

kaygudo gravatar image kaygudo  ( 2016-02-21 09:27:48 -0500 )edit

On the tutorial it is stated "the 2D map would re-appear again when a loop closure is found", so maybe no loop closure could be found (are there warnings on the console?). The map may be too small.

matlabbe gravatar image matlabbe  ( 2016-02-22 18:40:07 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-02-01 09:52:21 -0500

Seen: 2,082 times

Last updated: Feb 04 '16