Ask Your Question
0

How to edit and run the nav2d tutorial

asked 2016-02-01 08:11:03 -0600

RosUser gravatar image

I'm trying to edit the launch file by following tutorials for nav2d. So at the beginning I have download the package from github: https://github.com/skasperski/navigat... and past it in my catkin_ws, and run make Afterword when I try to run the one of the tutorials then it complain this:

roslaunch nav2d_tutorials tutorial2.launch

multiple files named [tutorial2.launch] in package [nav2d_tutorials]: - /opt/ros/indigo/share/nav2d_tutorials/launch/tutorial2.launch - /home/hjt/catkin_ws/src/navigation_2d-master/nav2d_tutorials/launch/tutorial2.launch Please specify full path instead The traceback for the exception was written to the log file

Then I tried to write the path but it did not work roslaunch nav2d_tutorials /home/hjt/catkin_ws/src/navigation_2d-master/nav2d_tutorials/launch/tutorial2.launch

What should I do, so I'm able to run the simulation with edited launch files ?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-02-01 09:05:24 -0600

Sebastian Kasperski gravatar image

updated 2016-02-02 07:08:06 -0600

Looks like you have both the binary version (in /opt/ros/indigo/...) and the source version (in /home/hjt/catkin_ws/src/...) installed. So make sure you build using catkin so the source version can correctly override the binary version.

cd /home/hjt/catkin_ws
source /opt/ros/indigo/setup.bash
catkin_make
source /home/hjt/catkin_ws/devel/setup.bash

Now after you build your workspace, you always have to source the setup.bash from this workspace in order to use it, not the one from /opt/ros/... Try this first, because as far as I know it should be no problem to have a package both as binary and source installed. Only if it doesn't work, try uninstalling the nav2d-binaries.

And yes, you shouldn't manually change anything in /opt/ros/.... But it is no problem to remove packages using the package manager of your choice (e.g. Synaptic) or just apt-get on the command line:

sudo apt-get remove ros-indigo-nav2d
edit flag offensive delete link more

Comments

Unfortunately it did not worked even when I run source /opt/ros/indigo/setup.bash and then catkin_make

RosUser gravatar imageRosUser ( 2016-02-01 09:36:51 -0600 )edit

Have you tried un-installing the binary version?

Sebastian Kasperski gravatar imageSebastian Kasperski ( 2016-02-02 04:40:31 -0600 )edit

No,because I have been told that I should not touch or edit anything in ROS installation folder! And I'm not sure how to un-install all nav2d packages so it dos not have any influence on other thing?

RosUser gravatar imageRosUser ( 2016-02-02 05:11:16 -0600 )edit

Thank you so much Sebastian for helping, I'm now able to run the simulation from my catkin_ws. I'm just missing the Robot icon in the RVIZ simulation but that is maybe because of I'm using Ros Indigo and as you mentioned befor that URDF was not supported.

RosUser gravatar imageRosUser ( 2016-02-02 09:16:57 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-02-01 08:11:03 -0600

Seen: 360 times

Last updated: Feb 02 '16