bash: /opt/ros/jade/setup.bash: No such file or directory [closed]

asked 2016-01-30 12:43:12 -0500

fayazvf gravatar image

updated 2016-01-31 13:40:43 -0500

Hi, I have been trying to install ros on my Ubuntu 14.04 using the instructions from http://wiki.ros.org/jade/Installation... . I have followed all the instructions as is but when I run bas, I get the error that setup.bash does not exist. I'm not sure if I'm missing anything. Please help. EDIT: I executed the following instructions:

$ sudo sh -c 'echo "deb http://packages.ros.org/ros/ubuntu $(lsb_release -sc) main" > /etc/apt/sources.list.d/ros-latest.list'
$ sudo apt-key adv --keyserver hkp://pool.sks-keyservers.net:80 --recv-key 0xB01FA116
$ sudo apt-get update
$ sudo apt-get install ros-jade-desktop-full
$ sudo rosdep init
$ rosdep update
$ echo "source /opt/ros/jade/setup.bash" >> ~/.bashrc
$ source ~/.bashrc
**bash: /opt/ros/jade/setup.bash: No such file or directory**
$ ls  /opt/ros/jade/
bin  include  lib  share
edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2018-09-24 12:14:45.306958

Comments

1

Pasting all the commands and their output might give us more info.

130s gravatar image130s ( 2016-01-30 18:02:56 -0500 )edit
1

Thanks for updating the info. I have no idea and I haven't found similar previous issues on this forum either. Was there any error printed during the installation? If I were you I would just purge ROS and redo installation...

130s gravatar image130s ( 2016-02-01 03:50:08 -0500 )edit

I don't know why is that happening, by the other hand Have you tried to install indigo version that is the right version for ubuntu 14.04?

jcardenasc93 gravatar imagejcardenasc93 ( 2016-03-18 20:18:17 -0500 )edit