Ask Your Question
0

robot rotation in place speed lower then minimum

asked 2016-01-24 08:35:51 -0500

Dor gravatar image

hello everyone i am having a difficulty with my robot. it navigates to a goal pretty well. the thing is when it needs to rotate at the end to the orientation of the goal it doesnt seem to move. when i look at the cmd_vel the robot receives a value of 0.457.. but the minimum value required for my robot to rotate is 0.55 this is also the value set in the base_local_planner_params so i dont get how can a value lower than the minimum is sent to the robot

please help me figure this one out

here is my base_local_planner_params file:

controller_frequency: 7.0
recovery_behavior_enabled: false
clearing_rotation_allowed: false

TrajectoryPlannerROS:
   max_vel_x: 0.4
   min_vel_x: 0.25
   max_rotational_vel: 0.79
   min_in_place_vel_theta: 0.55
   escape_vel: -0.3
   acc_lim_x: 0.05
   acc_lim_y: 0.5
   acc_lim_th: 0.07
   #min_rot_vel: 0.6
   #min_trans_vel: 0.6
   #max_trans_vel: 3.0
   #min_rotational_vel: 0.70

   holonomic_robot: false
   yaw_goal_tolerance: 0.5 # about 6 degrees
   xy_goal_tolerance: 0.8  # 5 cm
   latch_xy_goal_tolerance: true
   pdist_scale: 0.8
   gdist_scale: 0.4
   meter_scoring: true

   heading_lookahead: 0.325
   heading_scoring: false
   heading_scoring_timestep: 0.8
   occdist_scale: 0.1
   oscillation_reset_dist: 0.05
   publish_cost_grid_pc: false
   prune_plan: true

   sim_time: 2.0 
   # The amount of time to forward-simulate trajectories in seconds
   sim_granularity: 0.025 
   # The step size, in meters, to take between points on a given trajectory
   angular_sim_granularity: 0.025 
   # The step size, in radians, to take between angular samples on a given trajectory.
   vx_samples: 12  
   # The number of samples to use when exploring the x velocity space
   vtheta_samples: 20 
   # The number of samples to use when exploring the theta velocity space

   dwa: false
   simple_attractor: false
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-01-26 05:55:50 -0500

Dor gravatar image

i was able to find in the base_local_planner package in the trajectory planner cpp file a minimum value that was set too low 0.4 and i changed it to 0.6 and than things worked out :)

edit flag offensive delete link more

Comments

Are you saying your solution was to change the source code? That seems like a hokey fix, the parameter should be loaded via the yaml file. I am seeing the same general behavior. Move base commands my robot to turn at 0.4 rad/s even though I set my minimum to be 0.9. Anyone have a more permanent fix?

shoemakerlevy9 gravatar image shoemakerlevy9  ( 2018-08-03 17:22:29 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-01-24 08:35:51 -0500

Seen: 375 times

Last updated: Jan 26 '16