Cross compiling catkin project using Yocto ADT with meta-ros

asked 2016-01-20 03:34:24 -0500

sephalon gravatar image

Hi there!

Does somebody have experience in using a Yocto Application Development Toolkit (built with the meta-ros layer) for cross compiling a catkin project for an embedded target? I basically would like to offload the compile process to my workstation and deploy the project by mounting the catkin install folder using SSHFS from my embedded system.

What I tried so far: I built my own ADT, installed it on my workstation and wrote a toolchain.cmake file pointing to the cross compiler. Then I ran catkin like that:

catkin build -DCMAKE_TOOLCHAIN_PATH=toolchain.cmake -DCMAKE_PREFIX_PATH=/path/to/my/arm/sysroot

The compiler is detected nicely, but lots of stuff required by catkin like EmPy and the nosetests binary are missing in the x86 sysroot. Has somebody done this already and could guide me through the necessary steps of setup? I'd be also glad for any other hints on how to cross compile a ROS project for an embedded target.

Kind regards,


edit retag flag offensive close merge delete



Hi Sephalon,

have you made any progress on this?

Regards, Christian

graugans gravatar image graugans  ( 2016-03-09 08:20:03 -0500 )edit


is there any new knowledge about this topic? I'm standing in front of exactly the same problem. It would be very helpful to have access to a fully functional rostoolchain.cmake file.

Regards, Sven

lautenschlaeger gravatar image lautenschlaeger  ( 2019-05-22 02:53:30 -0500 )edit