Ask Your Question
0

Problem installing any package

asked 2016-01-17 03:42:01 -0500

updated 2016-01-17 05:19:22 -0500

Akif gravatar image

Hello! I am a newbie to ROS. Please bear with me.

Edit 1: I am unable to install any package now. I tried installing Turtlebot Simulator and I am getting the same error. I think there is some problem with ROS itself.

I am unable to install jackal simulator from clearpathrobotics. I get the following error -

E: Unable to locate package ros-indigo-jackal-simulator E: Unable to locate package ros-indigo-jackal-desktop

I am not sure why this is happening as I have ROS Indigo installed and running Ubuntu 14.04.3 LTS. I tried the installation after sudo-apt-get-update, and still I get the same error.

Can anyone please tell why I am unable to install?

Thank you.

edit retag flag offensive close merge delete

Comments

Did you install ROS through apt-get? Are you using ARM or x86?

ahendrix gravatar image ahendrix  ( 2016-01-17 03:58:52 -0500 )edit

Thru apt-get

Srinidhi gravatar image Srinidhi  ( 2016-01-17 04:18:02 -0500 )edit

Have you modified your /etc/apt/sources.list or any of the files in /etc/apt/sources.list.d/ since you installed ROS?

ahendrix gravatar image ahendrix  ( 2016-01-17 12:14:22 -0500 )edit

No. I have not modified the sources.list file. And there are no files in sources.list.d

Srinidhi gravatar image Srinidhi  ( 2016-01-21 07:04:41 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-01-21 12:10:21 -0500

ahendrix gravatar image

Using apt-get to install ROS packages assumes that you've installed ROS through apt.

Step 1.2 in the Jade for Ubuntu installation instructions should create a file called ros-latest.list in /etc/apt/sources.list.d. This is the sources file which tells apt where to find and download the ROS packages.

If that file doesn't exist, you need to repeat steps 1.2 and 1.3, and then run sudo apt-get update

edit flag offensive delete link more

Comments

Thank you very much! This fixed my problem. I am not sure why this happened. I was able to install the beginner tutorials without any problem though. Anyway, thanks again.

Srinidhi gravatar image Srinidhi  ( 2016-01-22 10:26:23 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-01-17 03:42:01 -0500

Seen: 456 times

Last updated: Jan 21 '16