Ask Your Question
0

Unable to run hokuyo_node for Hokuyo URG-04LX

asked 2016-01-12 09:03:36 -0500

schizzz8 gravatar image

updated 2016-01-12 10:58:10 -0500

Hi all,

I'm working on Surface Reconstruction from point cloud data and since in my lab there's an Hokuyo URG-04LX laser range finder, I would like to use it for building my data set. In order to get it working I followed this tutorial:

http://wiki.ros.org/hokuyo_node/Tutor...

In particular, I installed the ros node by running:

federico@HP-Compaq-8200:~$ sudo apt-get install ros-indigo-hokuyo-node

then, when I connect the laser to the PC, it gets associated to /dev/ttyUSB0 so I set the permissions for this port:

federico@HP-Compaq-8200:~$ ls -l /dev/ttyUSB0
crw-rw-rw- 1 root dialout 188, 0 gen 12 15:47 /dev/ttyUSB0

after this, I set the parameters for hokuyo_node:

federico@HP-Compaq-8200:~$ rosparam get /hokuyo_node/calibrate_time
false
federico@HP-Compaq-8200:~$ rosparam get /hokuyo_node/port 
/dev/ttyUSB0

as explained in the tutorial, but when I run the ROS node it gives me this error:

federico@HP-Compaq-8200:~$ rosrun hokuyo_node hokuyo_node 
[ERROR] [1452610493.392974859]: Exception thrown while opening Hokuyo.
timeout reached (in hokuyo::laser::laserReadline) You may find further details at http://www.ros.org/wiki/hokuyo_node/Troubleshooting

I really have no idea of what could cause this problem, so any help is greatly appreciated!!!

Thanks.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2016-01-12 11:06:37 -0500

ahendrix gravatar image

Almost every URG-04LX-UG01 that I've seen enumerates as /dev/ttyACM0 (or ACM1, ACM2, etc). Are you absolutely certain that your port setting is correct? Do you have the serial version of the lidar instead of the USB version?

The error timeout reached suggests that there isn't any data coming in on that port, or something else is reading that data first. You should be able to check which programs have that port open with sudo lsof | grep /dev/ttyUSB0. If there are any other programs using that port, you should figure out why and disable them.

edit flag offensive delete link more

Comments

Hi ahendrix! Thanks for your reply! My port setting was wrong, I was using only the serial connection. Thus, using also the usb connection solved the problem :)

schizzz8 gravatar imageschizzz8 ( 2016-01-13 04:43:55 -0500 )edit

Hello, may I ask how did you solved the problem? I'm having the same issue. When I connect the device, system log says it's connected to the USB0 port. How did you figured the right port?

ermanas gravatar imageermanas ( 2019-06-20 05:42:29 -0500 )edit
0

answered 2017-03-29 12:32:07 -0500

vin gravatar image

If the port is correct, there can be one more reason for this error. To solve this, you might try
sudo chmod 777 /dev/ttyACM0 (Change the port number according to your case). Hope this solves the problem. Check here for more details.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-01-12 09:03:36 -0500

Seen: 1,184 times

Last updated: Jan 12 '16