Ask Your Question
0

Linking problems on archlinux

asked 2015-12-24 17:44:36 -0600

veverak gravatar image

Hi folks, I've run into plenty of problems with building some things on arch with ros-jade...

I was able to compile most of the things, but I stuck on serveral errors...

at first, I tried to compile packages for raspi-cam and got stuck on camera_calibration_parser: (at first I tried script from AUR to install it, but then I made new catkin workspace, git cloned the package source and it still fails on same thing) https://bpaste.net/show/1afd33358e71

also, while ago I tried to compil jade-rviz, but too failed on linking phase https://bpaste.net/show/3ef53c30d3d2 ... (this time only AUR recipe) ... I tried to get help on author repo, but he said he can compile it just OK with same libraries as me on OS X....

I am using http://wiki.ros.org/jade/Installation... macro to setup ros enviroment when I work with it, and many packages I was able to get just right

what can cause this?

edit retag flag offensive close merge delete

Comments

It looks like you may be building new packages against the C++11 standard library, and the other ROS packages that you have installed might be built with an older C++ version. I don't know enough about the Arch build process to know for sure.

ahendrix gravatar imageahendrix ( 2015-12-24 23:03:02 -0600 )edit

The fact that you have trouble linking against core libraries like ros::console is very suspicious; that should never happen unless there's something wrong with your setup.

ahendrix gravatar imageahendrix ( 2015-12-24 23:03:49 -0600 )edit

ok, tried to recompile installed package.. it failed to link same way as previous things I mentioned :/ (random installed package, but I suppose I cam assume same far all I installed)

veverak gravatar imageveverak ( 2015-12-25 04:22:26 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-01-22 00:50:12 -0600

bchr gravatar image

updated 2016-01-22 00:50:51 -0600

Arch moved to the new C++ ABI in December. Thus it was required to rebuild all the packages depending on the old C++ ABI.

As for notifications through the AUR, I'm the one maintaining the ROS packages on Arch (see that project). When there is that kind of change (e.g. a new Boost release), I usually try to target the update by bumping the impacted packages. This takes time, and since I am quite busy at the moment, I relied on the user's know-how. Plus, some of the dependencies that I'm not maintaining have not been updated either, so the errors would still be propagated throughout the ROS packages if the user does not decide to reinstall the packages manually, and there's absolutely nothing I can do about that (except notifying the maintainers).

Also, I'm still using Indigo for work, so I haven't updated Jade packages in a long time. I'll try to do that during the next few weeks.

edit flag offensive delete link more
0

answered 2015-12-25 07:49:25 -0600

veverak gravatar image

Ok, I tried to reinstall all packages from ros-jade that I had (also with all dependencies that are not used by something else) and reinstalled everything

now I was able to install all packages that got broken link process.... and as far as I remember I installed 1/2 of ros-jade package suite around month or two ago... failed on non-ros-leated problem with one of the libraries, and week ago I finished instalation and eventually got into problems listed above...

for me it seems like during that period something in packages changed ... but than there is error in handling ros packages in AUR I suppose, because it should report 'new packages' :/

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-12-24 17:44:36 -0600

Seen: 82 times

Last updated: Jan 22 '16