Ask Your Question
0

CMake Error when building NAO packages

asked 2015-12-16 08:13:08 -0500

marcofe gravatar image

Hi, I need to interface NAO with ROS, and I followed the instructions on http://wiki.ros.org/nao/Tutorials/Ins... and http://wiki.ros.org/nao/Tutorials/Ins... . The only difference is that I have the 1.14.5 C++ SDK version of Naoqi, so I didn't install Python bindings. Then, I download the three packages nao_robot, naoqi_bridge and nao_extras, but when I build them I get the following error:

CMake Error at /opt/ros/indigo/share/catkin/cmake/catkinConfig.cmake:75 (find_package): 
Could not find a package configuration file provided by "naoqi_bridge_msgs" with any of the following names:

naoqi_bridge_msgsConfig.cmake
naoqi_bridge_msgs-config.cmake

Add the installation prefix of "naoqi_bridge_msgs" to CMAKE_PREFIX_PATH or set "naoqi_bridge_msgs_DIR" to a directory containing one of the above files.  If "naoqi_bridge_msgs" provides a separate development package or SDK, be sure it has been installed.

Call Stack (most recent call first):
    nao_extras/nao_teleop/CMakeLists.txt:13 (find_package)


 -- Configuring incomplete, errors occurred!

Can anyone help me to solve this problem? Thanks

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-12-17 02:20:02 -0500

BennyRe gravatar image

You are missing the naoqi_bridge_msgs package. You have to install it.

edit flag offensive delete link more

Comments

Yes, that was the issue. It really was a dummy question, sorry. Thanks a lot :)

marcofe gravatar image marcofe  ( 2016-01-24 05:50:34 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-12-16 08:13:08 -0500

Seen: 106 times

Last updated: Dec 17 '15