Ask Your Question
0

Using ikfast with 4DOF fails

asked 2015-12-04 07:47:26 -0500

Sietse gravatar image

Hello List,

to get my arm working in moveit, I try to create the ikfast code for a 4DOF with the commands:

rosrun collada_urdf urdf_to_collada my_robot.urdf my_robot.dae
rosrun moveit_ikfast round_collada_numbers.py my_robot.dae my_robot_rounded.dae 5
python `openrave-config --python-dir`/openravepy/_openravepy_/ikfast.py --robot=my_robot_rounded.dae --iktype=translationxaxisangleznorm4d --baselink=1 --eelink=5 --savefile=ikf.cpp

This always fails. First there is a warning:

/usr/local/share/openrave-0.9/plugins/openravepy_configurationcache.so: libconfigurationcache.so: cannot open shared object file: No such file or directory

But this file really exists!

Then at the end there is the following error:

File "/usr/local/lib/python2.7/dist-packages/sympy/matrices/matrices.py", line 2580, in matrix_multiply
raise ShapeError()  
sympy.matrices.matrices.ShapeError

I tried to make the urdf as simple as possible, it only consists of the needed links and joints. The urdf-file can be found at HERE

I tried more complicated urdf's and they work. I use ros-indigo and openrave-0.9 on ubuntu 14.04.

Hopefully someone can help, thanks in advance.

Sietse

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
0

answered 2016-02-01 14:10:25 -0500

Fredylucas gravatar image

When I generate my IKFast plugin for my manipulator, I must to install ROS Hydro for converting the URDF file to Collada, because Indigo didn't work.

edit flag offensive delete link more

Comments

Thanks for this workaround. I'll will try that.

Sietse gravatar image Sietse  ( 2016-02-02 01:50:13 -0500 )edit

converting URDF to collada worked for me without any problems. I am running indigo igloo on Ubuntu 14.04 LTS

Chickenman gravatar image Chickenman  ( 2016-02-03 05:41:00 -0500 )edit
0

answered 2016-02-03 05:43:57 -0500

Chickenman gravatar image

updated 2016-02-03 05:49:16 -0500

I used sympy 0.7.0 and latest stable openrave and I can generate IK without any problems. with indigo I used this tutorial for openrave latest stable instalation http://robots.uc3m.es/dox-teo-main/te...

edit flag offensive delete link more
0

answered 2016-02-02 02:24:35 -0500

Humpelstilzchen gravatar image

updated 2016-02-03 00:47:00 -0500

  • Please check if libconfigurationcache.so turns up in ldconfig -v.
  • Make sure you use an old python-sympy (version 0.7.1), newer do not work.

Btw why did you choose TranslationXAxisAngleZNorm4D? I don't see a translation in your urdf. It is not even implemented in the ros plugin, see ikfast61_moveit_plugin_template.cpp line 528

edit flag offensive delete link more

Comments

libconfigurationcache.so wasn't shown. I added it's directory to LD_LIBRARY_PATH, and the warning is gone. I have the correct version of sympy (via openrave install). But regrettably the error remains. Thanks.

Sietse gravatar image Sietse  ( 2016-02-02 15:00:11 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2015-12-04 07:47:26 -0500

Seen: 599 times

Last updated: Feb 03 '16