Ask Your Question
1

ros_control packages missing from Jade

asked 2015-11-30 00:01:26 -0600

Sam Bishop gravatar image

updated 2016-10-24 08:33:12 -0600

ngrennan gravatar image

I've just updated to Jade, and I'm having trouble running a Gazebo simulation using my previously working packages.

Right now I'm focused on this error:

File "/home/sam/aav-ros-car/aav_car_ws/src/aav_description/nodes/ackermann_controller.py", line 125, in <module>
    from controller_manager_msgs.srv import ListControllers
ImportError: No module named controller_manager_msgs.srv

I am seeing this too, though I think it's unrelated:

/opt/ros/jade/lib/gazebo_ros/gzclient: 17: .: Can't open /usr/share/gazebo//setup.sh
/opt/ros/jade/lib/gazebo_ros/gzserver: 22: .: Can't open /usr/share/gazebo//setup.sh

It looks like I am missing the service message definitions for ros_control, and that according to the wiki, this ought to be solved by sudo apt-get install ros-jade-ros-control ros-jade-ros-controllers. But that doesn't work either:

/opt/ros/jade$ sudo apt-get install ros-jade-ros-control ros-jade-ros-controllers
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package ros-jade-ros-control
E: Unable to locate package ros-jade-ros-controllers

This is on a standard 64-bit Intel system running Ubuntu 14.04. Here's the contents of my /etc/apt/sources.list.d/ros-latest.list:

deb http://packages.ros.org/ros/ubuntu trusty main

My system seems to otherwise be working fine.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
4

answered 2015-11-30 03:06:56 -0600

gvdhoorn gravatar image

I don't know why, but according to debbuild/jade.html?q=controller_manager_msgs, controller_manager_msgs (and almost all other ros_control packages) are not yet available in the public ROS package repositories. They should be installable from the shadow repository though.

That would explain why you can't apt-get install ros-jade-ros-control. Were you able to install any of the other ros_controlpackages on Jade?

edit flag offensive delete link more

Comments

Thank you so much! No, I hadnt' tried. It looks like the ros_control packages haven't been released for Jade yet. It hadn't occurred to me that a ROS release might not include such a critical set of packages. I assumed the fault was mine.

Sam Bishop gravatar imageSam Bishop ( 2015-11-30 09:01:32 -0600 )edit

The packages have been released, they just haven't reached the repositories most people use to install ROS from. If you setup your system to use the shadow-fixed repository (see the wiki page I linked), you can already install them on your Jade system. Otherwise, wait for the next sync.

gvdhoorn gravatar imagegvdhoorn ( 2015-11-30 09:06:54 -0600 )edit

Also: you can always build packages from source. I assume that is what most users have been doing with ros_control.

gvdhoorn gravatar imagegvdhoorn ( 2015-11-30 09:18:06 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-11-30 00:01:26 -0600

Seen: 419 times

Last updated: Nov 30 '15